summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2019-03-30 17:38:31 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-02-01 15:22:48 +0200
commit0cb85bc9eb54608aa28045ee1a45e02dc7041028 (patch)
tree2ada1e34c003ebfc6c30bc0dd84ad3af6f443be7 /app-admin/doctl
parentdev-libs/granite: bump to 5.5.0 (diff)
downloadgentoo-0cb85bc9eb54608aa28045ee1a45e02dc7041028.tar.gz
gentoo-0cb85bc9eb54608aa28045ee1a45e02dc7041028.tar.bz2
gentoo-0cb85bc9eb54608aa28045ee1a45e02dc7041028.zip
app-admin/doctl: new ebuild
A command line tool for DigitalOcean services Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua> Closes: https://github.com/gentoo/gentoo/pull/11546 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-admin/doctl')
-rw-r--r--app-admin/doctl/Manifest1
-rw-r--r--app-admin/doctl/doctl-1.55.0.ebuild40
-rw-r--r--app-admin/doctl/doctl-9999.ebuild46
-rw-r--r--app-admin/doctl/metadata.xml20
4 files changed, 107 insertions, 0 deletions
diff --git a/app-admin/doctl/Manifest b/app-admin/doctl/Manifest
new file mode 100644
index 000000000000..2b23d16cf2cd
--- /dev/null
+++ b/app-admin/doctl/Manifest
@@ -0,0 +1 @@
+DIST doctl-1.55.0.tar.gz 5157504 BLAKE2B 1d3db2ee4ca71a459456e72f035648c5ba73c5372c3369b360e1ee3cc44ec1155295e5f425611c307371f902c7ffed7dbce2f959266f79ecb8f149144fc86596 SHA512 6cea86e184ea25d5a6740d4090148fbe053ce93ebe8f2344f5a2bf62283381ed2a9574862a5ba39f34a52bf85af550313b7dd316a321f31089673f898d37cf78
diff --git a/app-admin/doctl/doctl-1.55.0.ebuild b/app-admin/doctl/doctl-1.55.0.ebuild
new file mode 100644
index 000000000000..8241168248ab
--- /dev/null
+++ b/app-admin/doctl/doctl-1.55.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="A command line tool for DigitalOcean services"
+HOMEPAGE="https://github.com/digitalocean/doctl"
+SRC_URI="https://github.com/digitalocean/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT BSD BSD-2 ISC MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_compile() {
+ GOFLAGS="-v -x -mod=vendor" \
+ go build ./cmd/... || die "build failed"
+
+ ./doctl completion bash > doctl.bash || die "completion for bash failed"
+ ./doctl completion zsh > doctl.zsh || die "completion for sh failed"
+ ./doctl completion fish > doctl.fish || die "completion for fish failed"
+}
+
+src_test() {
+ GOFLAGS="-v -x -mod=vendor" \
+ go test -work ./do/... ./pkg/... . || die "test failed"
+}
+
+src_install() {
+ einstalldocs
+ dobin doctl
+
+ newbashcomp doctl.bash doctl
+ insinto /usr/share/zsh/site-functions
+ newins doctl.zsh _doctl
+ insinto /usr/share/fish/completion
+ newins doctl.fish doctl
+}
diff --git a/app-admin/doctl/doctl-9999.ebuild b/app-admin/doctl/doctl-9999.ebuild
new file mode 100644
index 000000000000..59e3c4d9aa3c
--- /dev/null
+++ b/app-admin/doctl/doctl-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://github.com/digitalocean/${PN}.git"
+
+inherit bash-completion-r1 git-r3 go-module
+
+DESCRIPTION="A command line tool for DigitalOcean services"
+HOMEPAGE="https://github.com/digitalocean/doctl"
+SRC_URI=""
+
+LICENSE="Apache-2.0 MIT BSD BSD-2 ISC MPL-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+src_unpack() {
+ git-r3_src_unpack
+}
+
+src_compile() {
+ GOFLAGS="-v -x -mod=vendor" \
+ go build ./cmd/... || die "build failed"
+
+ ./doctl completion bash > doctl.bash || die "completion for bash failed"
+ ./doctl completion zsh > doctl.zsh || die "completion for sh failed"
+ ./doctl completion fish > doctl.fish || die "completion for fish failed"
+}
+
+src_test() {
+ GOFLAGS="-v -x -mod=vendor" \
+ go test -work ./do/... ./pkg/... . || die "test failed"
+}
+
+src_install() {
+ einstalldocs
+ dobin doctl
+
+ newbashcomp doctl.bash doctl
+ insinto /usr/share/zsh/site-functions
+ newins doctl.zsh _doctl
+ insinto /usr/share/fish/completion
+ newins doctl.fish doctl
+}
diff --git a/app-admin/doctl/metadata.xml b/app-admin/doctl/metadata.xml
new file mode 100644
index 000000000000..02d7430b53ae
--- /dev/null
+++ b/app-admin/doctl/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>spiderx@spiderx.dp.ua</email>
+ <name>Vladimir Pavljuchenkov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ The official DigitalOcean command-line client,
+ which leverages the DigitalOcean API to provide access
+ to DigitalOcean services.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">digitalocean/doctl</remote-id>
+ </upstream>
+</pkgmetadata>