summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-04-17 10:27:05 +0200
committerHans de Graaff <graaff@gentoo.org>2017-04-17 10:56:29 +0200
commit70eff33494d6e8315bf46eb3c0cf1d4bb9e00409 (patch)
treea3f3b44800df1d0de985f3e3954dc4326e7954e8 /app-admin/ec2-ami-tools/ec2-ami-tools-1.5.7.ebuild
parentdev-perl/Email-Address-List: Fix missing test dep on dev-perl/JSON (diff)
downloadgentoo-70eff33494d6e8315bf46eb3c0cf1d4bb9e00409.tar.gz
gentoo-70eff33494d6e8315bf46eb3c0cf1d4bb9e00409.tar.bz2
gentoo-70eff33494d6e8315bf46eb3c0cf1d4bb9e00409.zip
app-admin/ec2-ami-tools: add 1.5.7, add ruby22, EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-admin/ec2-ami-tools/ec2-ami-tools-1.5.7.ebuild')
-rw-r--r--app-admin/ec2-ami-tools/ec2-ami-tools-1.5.7.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-admin/ec2-ami-tools/ec2-ami-tools-1.5.7.ebuild b/app-admin/ec2-ami-tools/ec2-ami-tools-1.5.7.ebuild
new file mode 100644
index 000000000000..a34688a3ac48
--- /dev/null
+++ b/app-admin/ec2-ami-tools/ec2-ami-tools-1.5.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+USE_RUBY="ruby21 ruby22"
+
+inherit ruby-single versionator
+
+DESCRIPTION="Command-line tools that serve as client interface to the Amazon EC2 web service"
+HOMEPAGE="http://developer.amazonwebservices.com/connect/entry.jspa?externalID=368&categoryID=88"
+SRC_URI="http://s3.amazonaws.com/ec2-downloads/${P}.zip"
+
+LICENSE="Amazon
+ || ( Ruby GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND="
+ ${RUBY_DEPS}
+ virtual/ruby-ssl
+ net-misc/rsync
+ net-misc/curl"
+
+src_prepare() {
+ # Remove a left behind license file.
+ rm -f lib/ec2/oem/LICENSE.txt || die 'Removal of LICENSE failed.'
+
+ eapply_user
+}
+
+src_install() {
+ dobin bin/*
+
+ insinto /usr
+ doins -r lib
+
+ insinto /etc/ec2/amitools
+ doins etc/ec2/amitools/*
+
+ dodir /etc/env.d
+ echo "EC2_AMITOOL_HOME=/usr" >> "${T}"/99${PN} || die "Can't write environment variable."
+ doenvd "${T}"/99${PN}
+}
+
+pkg_postinst() {
+ ewarn "Remember to run \`env-update && source /etc/profile\` if you plan"
+ ewarn "to use these tools in a shell before logging out (or restarting"
+ ewarn "your login manager)."
+}