summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/elektra/elektra-0.7.1-r5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/elektra/elektra-0.7.1-r5.ebuild')
-rw-r--r--app-admin/elektra/elektra-0.7.1-r5.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/elektra/elektra-0.7.1-r5.ebuild b/app-admin/elektra/elektra-0.7.1-r5.ebuild
new file mode 100644
index 000000000000..a15dac611bf5
--- /dev/null
+++ b/app-admin/elektra/elektra-0.7.1-r5.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools autotools-multilib eutils multilib
+
+DESCRIPTION="universal and secure framework to store config parameters in a hierarchical key-value pair mechanism"
+HOMEPAGE="http://freedesktop.org/wiki/Software/Elektra"
+SRC_URI="ftp://ftp.markus-raab.org/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gcov iconv static-libs test"
+
+RDEPEND="dev-libs/libxml2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ sys-devel/libtool[${MULTILIB_USEDEP}]
+ iconv? ( virtual/libiconv[${MULTILIB_USEDEP}] )"
+
+src_prepare() {
+ einfo 'Removing bundled libltdl'
+ rm -rf libltdl || die
+
+ epatch \
+ "${FILESDIR}"/${P}-test.patch \
+ "${FILESDIR}"/${P}-ltdl.patch \
+ "${FILESDIR}"/${P}-automake-1.12.patch \
+ "${FILESDIR}"/${P}-remove-ddefault-link.patch
+
+ touch config.rpath
+ eautoreconf
+}
+
+src_configure() {
+ # berkeleydb, daemon, fstab, gconf, python do not work
+ # avoid collision with kerberos (bug 403025, 447246)
+ local myeconfargs=(
+ --enable-filesys
+ --enable-hosts
+ --enable-ini
+ --enable-passwd
+ --disable-berkeleydb
+ --disable-fstab
+ --disable-gconf
+ --disable-daemon
+ --enable-cpp
+ --disable-python
+ $(use_enable gcov)
+ $(use_enable iconv)
+ $(use_enable static-libs static)
+ --with-docdir=/usr/share/doc/${PF}
+ --with-develdocdir=/usr/share/doc/${PF}a
+ --includedir=/usr/include/${PN}
+ )
+ autotools-multilib_src_configure
+ dodir /usr/share/man/man3
+}
+
+src_compile() {
+ autotools-multilib_src_compile LIBLTDL=-lltdl
+}
+
+src_install() {
+ autotools-multilib_src_install
+
+ #avoid collision with allegro (bug 409305)
+ local my_f=""
+ for my_f in $(find "${D}"/usr/share/man/man3 -name "key.3*") ; do
+ mv "${my_f}" "${my_f/key/elektra-key}" || die
+ elog "/usr/share/man/man3/$(basename "${my_f}") installed as $(basename "${my_f/key/elektra-key}")"
+ done
+
+ if ! use static-libs; then
+ find "${D}" -name "*.a" -delete || die
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}