summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-03-14 23:47:26 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-03-15 00:46:03 +0100
commite119efb038055bbc726bb6ae7145a8f713bdf1ec (patch)
treea1f4b77585d830b22c25075d00389c4088020b94 /app-admin/entr/entr-3.7.ebuild
parentapp-text/tidy-html5: version bump. (diff)
downloadgentoo-e119efb038055bbc726bb6ae7145a8f713bdf1ec.tar.gz
gentoo-e119efb038055bbc726bb6ae7145a8f713bdf1ec.tar.bz2
gentoo-e119efb038055bbc726bb6ae7145a8f713bdf1ec.zip
app-admin/entr: version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-admin/entr/entr-3.7.ebuild')
-rw-r--r--app-admin/entr/entr-3.7.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/entr/entr-3.7.ebuild b/app-admin/entr/entr-3.7.ebuild
new file mode 100644
index 000000000000..41caf72596a4
--- /dev/null
+++ b/app-admin/entr/entr-3.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Run arbitrary commands when files change"
+HOMEPAGE="http://entrproject.org"
+SRC_URI="http://entrproject.org/code/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ mv eradman-* "${P}" || die
+}
+
+src_configure() {
+ sh configure || die
+ sed -i -e 's#\(^PREFIX \).*#\1\?= /usr#' Makefile.bsd || die
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}