summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2019-10-01 23:23:48 +0200
committerPatrice Clement <monsieurp@gentoo.org>2019-10-01 23:23:48 +0200
commitda2e8d37322036c58c9df0be69645edcf53fc42d (patch)
tree05a3f82dcc6db8f3a5e19165a54ecb78f77286aa /app-admin/entr/entr-4.3.ebuild
parentdev-util/rocminfo: 2.9.0 version bump (diff)
downloadgentoo-da2e8d37322036c58c9df0be69645edcf53fc42d.tar.gz
gentoo-da2e8d37322036c58c9df0be69645edcf53fc42d.tar.bz2
gentoo-da2e8d37322036c58c9df0be69645edcf53fc42d.zip
app-admin/entr: version bump.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'app-admin/entr/entr-4.3.ebuild')
-rw-r--r--app-admin/entr/entr-4.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/entr/entr-4.3.ebuild b/app-admin/entr/entr-4.3.ebuild
new file mode 100644
index 000000000000..b42d1f975478
--- /dev/null
+++ b/app-admin/entr/entr-4.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Run arbitrary commands when files change"
+HOMEPAGE="http://entrproject.org"
+SRC_URI="http://entrproject.org/code/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd"
+IUSE="test"
+
+src_configure() {
+ sh configure || die
+ sed -i -e 's#\(^PREFIX \).*#\1\?= /usr#' Makefile.bsd || die
+}
+
+src_compile() {
+ export CC=$(tc-getCC)
+ default
+}
+
+src_test() {
+ export CC=$(tc-getCC)
+ default
+}