summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2020-11-06 15:34:30 +0100
committerAgostino Sarubbo <ago@gentoo.org>2020-11-06 15:34:30 +0100
commit514dd6cd323bafa86b1d5d80407fa7a85f53c464 (patch)
tree0aceb5c892bf70ece0af183588ffdef22d86b02e /app-admin/exo
parentsci-visualization/gnuplot: Use virtualx for tests. (diff)
downloadgentoo-514dd6cd323bafa86b1d5d80407fa7a85f53c464.tar.gz
gentoo-514dd6cd323bafa86b1d5d80407fa7a85f53c464.tar.bz2
gentoo-514dd6cd323bafa86b1d5d80407fa7a85f53c464.zip
app-admin/exo: version bump to 1.20.2
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'app-admin/exo')
-rw-r--r--app-admin/exo/Manifest1
-rw-r--r--app-admin/exo/exo-1.20.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/exo/Manifest b/app-admin/exo/Manifest
index 451c2331eb39..d8a70392502f 100644
--- a/app-admin/exo/Manifest
+++ b/app-admin/exo/Manifest
@@ -1 +1,2 @@
DIST exo-1.19.0.tar.gz 4624195 BLAKE2B 49b1e39ac7a9893620b9694d088a5d8681602c51f25288f9ace5ee7ea5f213626e9c5a3817f8e26a0608446c79e175db98a83bca270a9d6d6914f57ccc8e4478 SHA512 acd0b11b5f858288601f32254647e0d2d79f06a79b5b4fe7d6dc72b5f6040b5e52d88648d5eb574bbec7cb47e80358c368369d569255773048ee4e54f4d14dea
+DIST exo-1.20.2.tar.gz 4623465 BLAKE2B 07d19c95e06ec0bc43d5d70d332be50dcba623740ea60316640bfeffa6f6378f6d57bc474a8accc10e685d9c5816acc9fef140fc47999a93dd3f42d982adf282 SHA512 9618973b3038e6bdce7cc8a324715d0a95bd75eb4d2c96919370ea3840b0cdda315cd8e1d26f6d56505a984d2de8606d97783072286143359c0b271d151181dd
diff --git a/app-admin/exo/exo-1.20.2.ebuild b/app-admin/exo/exo-1.20.2.ebuild
new file mode 100644
index 000000000000..0c2c8d861fe4
--- /dev/null
+++ b/app-admin/exo/exo-1.20.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns."
+HOMEPAGE="https://github.com/exoscale/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND="dev-lang/go:="
+RESTRICT="strip"
+QA_FLAGS_IGNORED=".*"
+
+S="${WORKDIR}/cli-${PV}"
+
+src_compile() {
+ go build -mod vendor -o ${PN} || die "build failed"
+}
+
+src_test() {
+ # run at least 'exo version' for test
+ ./exo version > /dev/null 2>&1
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}