summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2019-11-12 14:49:52 +0100
committerAgostino Sarubbo <ago@gentoo.org>2019-11-12 14:49:52 +0100
commit77230ef71377c0b45f0510ed089fb10d7097093f (patch)
tree108d6cdc650c41be180325b7ecd11e7a10b5d1b1 /app-admin/exo
parentdev-python/hcloud-python: amd64 stable (diff)
downloadgentoo-77230ef71377c0b45f0510ed089fb10d7097093f.tar.gz
gentoo-77230ef71377c0b45f0510ed089fb10d7097093f.tar.bz2
gentoo-77230ef71377c0b45f0510ed089fb10d7097093f.zip
app-admin/exo: version bump to 1.6.0
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'app-admin/exo')
-rw-r--r--app-admin/exo/Manifest1
-rw-r--r--app-admin/exo/exo-1.6.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/app-admin/exo/Manifest b/app-admin/exo/Manifest
index da68885f77a6..6eaca6600925 100644
--- a/app-admin/exo/Manifest
+++ b/app-admin/exo/Manifest
@@ -1,2 +1,3 @@
DIST exo-1.5.0.tar.gz 3806818 BLAKE2B fe817962ebcebfbe37c0ec884b127144fca4d85bf985f3f6d98bf154a1bb17b49d8b7de7ece6fb71ae3b2793969fdae8bf0ad0f2031cc11943c714e27ef1a63d SHA512 3fab4c57d55d0058a4e1191d97ac04de45052e5f9c25bea0d4408df48c648e28804842d8989700daf36c6657023b99a63a4dd77a1991689abecdb11afa4e6a09
DIST exo-1.5.1.tar.gz 3806840 BLAKE2B 4a99fd15049ece0349ce427beb923e8ecf7ad47980412a9aced9f7ccbb340c2e95d08045fd553967f5c428d46505ff48e4eccca442cb796d845c6174a68a8b5b SHA512 2db42813446e79a4bd06048706f4a775c435c33fe7f9bf82c260623c0b09ad28e9090cf11b52b5d1c7b2a4ef693af6cede0a2470b3d8213fb655c27cc6d1f58d
+DIST exo-1.6.0.tar.gz 3754205 BLAKE2B 9dc109ec33e9a11199f49adc45b388e1c3c62ebc060b300568fd42c5b6457b1c0373939b325c0b0be462dfacf3d842a7eca66a01efd8685d6f621401423448ed SHA512 8d00dd24ef8098c156e756d082c039e9753fefc11b415435725f536faa5fa8e4eb652ff8c0c82452ab84512f7491aee970d425910bfcb2529568589e5dc9c6d2
diff --git a/app-admin/exo/exo-1.6.0.ebuild b/app-admin/exo/exo-1.6.0.ebuild
new file mode 100644
index 000000000000..ebb329b957ff
--- /dev/null
+++ b/app-admin/exo/exo-1.6.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns."
+HOMEPAGE="https://exoscale.github.io/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND="dev-lang/go:="
+RESTRICT="strip"
+
+S="${WORKDIR}/cli-${PV}"
+
+src_compile() {
+ go build -mod vendor -o ${PN} || die "build failed"
+}
+
+src_install() {
+ dobin ${PN}
+}