summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-09-02 00:20:00 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-09-02 00:20:00 +0200
commit2bfc5fe2a380a38cc0995c4ace48803097d22597 (patch)
treea7d73484e0ee281f78a174945c125d6fab6ac97b /app-admin/fleet/fleet-0.11.8.ebuild
parentnet-print/hplip-plugin: Version bump to 3.16.8 (diff)
downloadgentoo-2bfc5fe2a380a38cc0995c4ace48803097d22597.tar.gz
gentoo-2bfc5fe2a380a38cc0995c4ace48803097d22597.tar.bz2
gentoo-2bfc5fe2a380a38cc0995c4ace48803097d22597.zip
app-admin/fleet: Version bump to 0.11.8
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-admin/fleet/fleet-0.11.8.ebuild')
-rw-r--r--app-admin/fleet/fleet-0.11.8.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-admin/fleet/fleet-0.11.8.ebuild b/app-admin/fleet/fleet-0.11.8.ebuild
new file mode 100644
index 000000000000..9a5241dbda0c
--- /dev/null
+++ b/app-admin/fleet/fleet-0.11.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGO_PN="github.com/coreos/fleet"
+
+inherit systemd vcs-snapshot
+
+DESCRIPTION="A Distributed init System"
+HOMEPAGE="https://github.com/coreos/fleet"
+SRC_URI="https://github.com/coreos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples test"
+
+DEPEND="
+ >=dev-lang/go-1.4:=
+ test? ( dev-go/go-tools )
+"
+RDEPEND=""
+
+src_compile() {
+ ./build || die 'Build failed'
+}
+
+src_test() {
+ ./test || die 'Tests failed'
+}
+
+src_install() {
+ dobin "${S}"/bin/fleetd
+ dobin "${S}"/bin/fleetctl
+
+ systemd_dounit "${FILESDIR}"/fleet.service
+ systemd_dounit "${FILESDIR}"/fleet.socket
+
+ dodoc README.md
+ use doc && dodoc -r Documentation
+ use examples && dodoc -r examples
+
+ insinto /etc/${PN}
+ newins "${PN}".conf.sample "${PN}".conf
+}