summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/fsvs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/fsvs')
-rw-r--r--app-admin/fsvs/Manifest1
-rw-r--r--app-admin/fsvs/files/fsvs-1.2.5-as-needed.patch31
-rw-r--r--app-admin/fsvs/fsvs-1.2.5-r1.ebuild56
-rw-r--r--app-admin/fsvs/metadata.xml7
4 files changed, 95 insertions, 0 deletions
diff --git a/app-admin/fsvs/Manifest b/app-admin/fsvs/Manifest
new file mode 100644
index 000000000000..56895c8ce946
--- /dev/null
+++ b/app-admin/fsvs/Manifest
@@ -0,0 +1 @@
+DIST fsvs-1.2.5.tar.bz2 427494 SHA256 3c957d29e0e568d46ce2fd659a88ed6ea93a05267bdc11dc93131a88b7cb44d2 SHA512 36ab5d04491d506b2891548f3ad458e7977bbd2e7d4b03e135b13d07adb22aedb261c28d5ddd3df895771806ef54c1bca6a1ef7bc5aa2e50e4b234ddf6cbe19c WHIRLPOOL c44213b5f2ce42ad67914fe07198a4f8404b9303d59806e521059d1f5b6335ef6ba3b84862bb9b890b8a29ef2b4543f2e897ef341c16ccb96e6e7a6d1ac8dd66
diff --git a/app-admin/fsvs/files/fsvs-1.2.5-as-needed.patch b/app-admin/fsvs/files/fsvs-1.2.5-as-needed.patch
new file mode 100644
index 000000000000..6f833116f937
--- /dev/null
+++ b/app-admin/fsvs/files/fsvs-1.2.5-as-needed.patch
@@ -0,0 +1,31 @@
+Fixes --as-needed support(bug #294834)
+Verbose build
+Fixes underlinking(bug #463684) - patch went upstream
+
+--- src/Makefile.in.orig 2011-11-11 22:19:12.000000000 +0400
++++ src/Makefile.in 2013-08-19 13:30:16.186082295 +0400
+@@ -18,7 +18,7 @@
+ CFLAGS := @CFLAGS@ @NEED_FNESTED_FUNCTIONS@
+ CFLAGS += -Wall -funsigned-char -Os -DFSVS_VERSION='"$(VERSION)"'
+ LDFLAGS := @LDFLAGS@
+-FSVS_LDFLAGS = $(LDFLAGS) -lsvn_subr-1 -lsvn_delta-1 -lsvn_ra-1 -lpcre -lgdbm
++FSVS_LIBS = -lsvn_subr-1 -lsvn_delta-1 -lsvn_ra-1 -lpcre -lgdbm -ldl
+ EXTRALIBS := @EXTRALIBS@
+ WAA_CHARS?= @WAA_WC_MD5_CHARS@
+
+@@ -146,13 +146,13 @@
+ ################################ Rules ######################################
+ %.o: %.c
+ @echo " CC $<"
+- @$(CC) $(CFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) -c -o $@ $<
+
+ # if the Makefile has changed, the output will (at least sometimes)
+ # change, too.
+ $(DEST): $(C_FILES:%.c=%.o)
+ @echo " Link $@"
+- @$(CC) $(FSVS_LDFLAGS) $(LDLIBS) $(LIBS) $(EXTRALIBS) -o $@ $^
++ $(CC) -o $@ $^ $(LDFLAGS) $(LDLIBS) $(LIBS) $(FSVS_LIBS) $(EXTRALIBS)
+ ifeq (@ENABLE_RELEASE@, 1)
+ -strip $@
+ endif
diff --git a/app-admin/fsvs/fsvs-1.2.5-r1.ebuild b/app-admin/fsvs/fsvs-1.2.5-r1.ebuild
new file mode 100644
index 000000000000..de9ee8495327
--- /dev/null
+++ b/app-admin/fsvs/fsvs-1.2.5-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Backup/restore for subversion backends"
+HOMEPAGE="http://fsvs.tigris.org/"
+SRC_URI="http://download.fsvs-software.org/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-vcs/subversion
+ dev-libs/libpcre
+ sys-libs/gdbm
+ dev-libs/apr-util
+ dev-util/ctags"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+ epatch_user
+}
+
+src_compile() {
+ # respect compiler
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin src/fsvs
+ dodir /etc/fsvs
+ keepdir /var/spool/fsvs
+ doman doc/*5 doc/*1
+ dodoc doc/{FAQ,IGNORING,PERFORMANCE,USAGE}
+}
+
+pkg_postinst() {
+ elog "Remember, this system works best when you're connecting to a remote"
+ elog "svn server."
+ elog
+ elog "Go to the base path for versioning:"
+ elog " cd /"
+ elog "Tell fsvs which URL it should use:"
+ elog " fsvs url svn+ssh://username@machine/path/to/repos"
+ elog "Define ignore patterns - all virtual filesystems (/proc, /sys, etc.),"
+ elog "and (assuming that you're in / currently) the temporary files in /tmp:"
+ elog " fsvs ignore DEVICE:0 ./tmp/*"
+ elog "And you're ready to play!"
+ elog "Check your data in:"
+ elog " fsvs commit -m \"First import\""
+}
diff --git a/app-admin/fsvs/metadata.xml b/app-admin/fsvs/metadata.xml
new file mode 100644
index 000000000000..ff62877c67ae
--- /dev/null
+++ b/app-admin/fsvs/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>