summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2020-05-01 14:17:39 +0200
committerAgostino Sarubbo <ago@gentoo.org>2020-05-01 14:17:39 +0200
commit82905167ecce4b0f685ee16555d4433e011f10b9 (patch)
treed511a5f4c8349c811f623b08b88ae0c8cc522e20 /app-admin/hcloud
parentkde-apps/akonadi: Drop ~arm keyword (diff)
downloadgentoo-82905167ecce4b0f685ee16555d4433e011f10b9.tar.gz
gentoo-82905167ecce4b0f685ee16555d4433e011f10b9.tar.bz2
gentoo-82905167ecce4b0f685ee16555d4433e011f10b9.zip
app-admin/hcloud: enable simple test
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'app-admin/hcloud')
-rw-r--r--app-admin/hcloud/hcloud-1.16.2.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/app-admin/hcloud/hcloud-1.16.2.ebuild b/app-admin/hcloud/hcloud-1.16.2.ebuild
index f5620e0f972f..4748be94a842 100644
--- a/app-admin/hcloud/hcloud-1.16.2.ebuild
+++ b/app-admin/hcloud/hcloud-1.16.2.ebuild
@@ -19,6 +19,15 @@ src_compile() {
go build -mod vendor -o ${PN} -ldflags "-w -X github.com/hetznercloud/cli/cli.Version=${PV}-gentoo" ./cmd/${PN} || die "build failed"
}
+src_test() {
+ # For upstream a simple test is run 'hcloud version'
+ ./hcloud version
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
src_install() {
dobin ${PN}
}