summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2021-03-16 12:00:54 +0100
committerAgostino Sarubbo <ago@gentoo.org>2021-03-16 12:00:54 +0100
commitf55d5b3b480f6945846d68a4d077a4e17532440c (patch)
treec97bd6518fcd6505bff39c3c945fc5ac766e1d72 /app-admin/hcloud
parentmedia-sound/qjackctl: bump to 0.9.2 (diff)
downloadgentoo-f55d5b3b480f6945846d68a4d077a4e17532440c.tar.gz
gentoo-f55d5b3b480f6945846d68a4d077a4e17532440c.tar.bz2
gentoo-f55d5b3b480f6945846d68a4d077a4e17532440c.zip
app-admin/hcloud: version bump to 1.21.0
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'app-admin/hcloud')
-rw-r--r--app-admin/hcloud/Manifest1
-rw-r--r--app-admin/hcloud/hcloud-1.21.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-admin/hcloud/Manifest b/app-admin/hcloud/Manifest
index e88a924acae3..b305c1888a95 100644
--- a/app-admin/hcloud/Manifest
+++ b/app-admin/hcloud/Manifest
@@ -1 +1,2 @@
DIST hcloud-1.20.0.tar.xz 790040 BLAKE2B ba0d62c8e817daadaa9eb891adb3f655a9ae33b05617449e26b09a3ba6b99a6b6f61df1cf29138a008a7ee58e45efdfe07c408af89efb1c2bd870d7340976bb8 SHA512 5dbb9060595e836ccde99984783954e894f74c098f911ae8c4cc1944d444fd28b6f722bb711d9b1ae245ddf3af8cca1939585ed778c8026fbf8c4201c2d15469
+DIST hcloud-1.21.0.tar.xz 823556 BLAKE2B 8a37c7854d6c74f58a8f9dd021674a19f1cc968901e109dadf2e1b7621c3dd4981b07939334b293419d42fc8d1b1a1ff04b962a40b0ae8bf2518a0f7cccd7c68 SHA512 3186839ed95f355f67bdf7169dfa0b10852c8e2e3dc0f2a30e712072cd06cc69a40b038cfa214a47d33e39707d00a81f781aae7f51773cdaca96bcc0b80b1dec
diff --git a/app-admin/hcloud/hcloud-1.21.0.ebuild b/app-admin/hcloud/hcloud-1.21.0.ebuild
new file mode 100644
index 000000000000..77d54006fe99
--- /dev/null
+++ b/app-admin/hcloud/hcloud-1.21.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A command-line interface for Hetzner Cloud"
+HOMEPAGE="https://github.com/hetznercloud/cli"
+SRC_URI="https://dev.gentoo.org/~ago/distfiles/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND="dev-lang/go:="
+RESTRICT="strip"
+QA_FLAGS_IGNORED=".*"
+
+src_compile() {
+ go build -mod vendor -o ${PN} -ldflags "-w -X github.com/hetznercloud/cli/cli.Version=${PV}-gentoo" ./cmd/${PN} || die "build failed"
+}
+
+src_test() {
+ # For upstream a simple test is run 'hcloud version'
+ ./hcloud version
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}