summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-29 18:11:43 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-29 23:30:44 +0100
commit0f3fe7cf3bb7da7b34fbdd9ebde6b2a7cebcf953 (patch)
treeb2ff08b05f6cace3e33e3a2f29bc9502bf03207a /app-admin/ide-smart
parentdev-util/kdevelop-php: Restrict tests (diff)
downloadgentoo-0f3fe7cf3bb7da7b34fbdd9ebde6b2a7cebcf953.tar.gz
gentoo-0f3fe7cf3bb7da7b34fbdd9ebde6b2a7cebcf953.tar.bz2
gentoo-0f3fe7cf3bb7da7b34fbdd9ebde6b2a7cebcf953.zip
app-admin/ide-smart: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-admin/ide-smart')
-rw-r--r--app-admin/ide-smart/files/ide-smart-1.4-fix-build-system.patch17
-rw-r--r--app-admin/ide-smart/ide-smart-1.4-r1.ebuild22
2 files changed, 34 insertions, 5 deletions
diff --git a/app-admin/ide-smart/files/ide-smart-1.4-fix-build-system.patch b/app-admin/ide-smart/files/ide-smart-1.4-fix-build-system.patch
new file mode 100644
index 000000000000..ad523e36b3f9
--- /dev/null
+++ b/app-admin/ide-smart/files/ide-smart-1.4-fix-build-system.patch
@@ -0,0 +1,17 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,13 +2,10 @@
+
+ #CC = gcc
+ PROF = -g0 -O2
+-CFLAGS = $(PROF) -Wall
+-LDFLAGS = $(PROF)
++CFLAGS += -Wall
+ TARGET = ide-smart
+ OBJECTS = ide-smart.o
+
+-ide-smart: $(OBJECTS)
+- $(CC) $(LDFLAGS) -o $(TARGET) $(OBJECTS)
+
+ all: ide-smart
+
diff --git a/app-admin/ide-smart/ide-smart-1.4-r1.ebuild b/app-admin/ide-smart/ide-smart-1.4-r1.ebuild
index cac5d77934f3..5ffb6e04cbb2 100644
--- a/app-admin/ide-smart/ide-smart-1.4-r1.ebuild
+++ b/app-admin/ide-smart/ide-smart-1.4-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
inherit toolchain-funcs
DESCRIPTION="A tool to read SMART information from harddiscs"
@@ -12,12 +14,22 @@ SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
IUSE=""
-src_compile() {
- $(tc-getCC) ${CFLAGS} -Wall ${LDFLAGS} -o ${PN} ${PN}.c || die "compile"
+PATCHES=( "${FILESDIR}"/${PN}-1.4-fix-build-system.patch )
+
+src_prepare() {
+ default
+
+ # yes, the tarball includes pre-compiled
+ # object files and binaries
+ rm ${PN}{,.o} || die
+}
+
+src_configure() {
+ tc-export CC
}
src_install() {
- dobin ide-smart || die
+ dobin ide-smart
doman ide-smart.8
- dodoc README
+ einstalldocs
}