summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2016-09-01 15:40:21 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2016-09-01 15:44:02 -0400
commit6e24f866b3ca5fbcc79d7c63fbf65c8f2c44ff37 (patch)
tree69c167ae9373b0323d664cc969e6895f7d0b2ee7 /app-admin/lastpass-cli/lastpass-cli-1.0.0.ebuild
parentx11-misc/rofi: Old. (diff)
downloadgentoo-6e24f866b3ca5fbcc79d7c63fbf65c8f2c44ff37.tar.gz
gentoo-6e24f866b3ca5fbcc79d7c63fbf65c8f2c44ff37.tar.bz2
gentoo-6e24f866b3ca5fbcc79d7c63fbf65c8f2c44ff37.zip
app-admin/lastpass-cli: version bump to 1.0.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-admin/lastpass-cli/lastpass-cli-1.0.0.ebuild')
-rw-r--r--app-admin/lastpass-cli/lastpass-cli-1.0.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-admin/lastpass-cli/lastpass-cli-1.0.0.ebuild b/app-admin/lastpass-cli/lastpass-cli-1.0.0.ebuild
new file mode 100644
index 000000000000..d98653777a34
--- /dev/null
+++ b/app-admin/lastpass-cli/lastpass-cli-1.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit bash-completion-r1 toolchain-funcs
+
+DESCRIPTION="Interfaces with LastPass.com from the command line."
+HOMEPAGE="https://github.com/lastpass/lastpass-cli"
+SRC_URI="https://github.com/lastpass/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl X +pinentry"
+
+RDEPEND="
+ X? ( || ( x11-misc/xclip x11-misc/xsel ) )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ net-misc/curl
+ dev-libs/libxml2
+ pinentry? ( app-crypt/pinentry )
+"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not include headers from /usr/local/include
+ sed -i -e 's:-I/usr/local/include::' Makefile || die
+ default
+ tc-export CC
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}/usr" COMPDIR="$(get_bashcompdir)" all doc-man
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install install-doc
+}