summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2018-03-15 20:30:45 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2018-03-15 20:30:45 -0400
commit5fa8ca5f43c4aa55bbb641e494db9ea76d4e57ee (patch)
tree181cabf5c53c9d2285849645876c71ce496489f2 /app-admin/lastpass-cli/lastpass-cli-1.3.0.ebuild
parentgames-action/super-hexagon: Bump to 20160217, EAPI 6, no bundling (diff)
downloadgentoo-5fa8ca5f43c4aa55bbb641e494db9ea76d4e57ee.tar.gz
gentoo-5fa8ca5f43c4aa55bbb641e494db9ea76d4e57ee.tar.bz2
gentoo-5fa8ca5f43c4aa55bbb641e494db9ea76d4e57ee.zip
app-admin/lastpass-cli: bump to 1.3.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-admin/lastpass-cli/lastpass-cli-1.3.0.ebuild')
-rw-r--r--app-admin/lastpass-cli/lastpass-cli-1.3.0.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-admin/lastpass-cli/lastpass-cli-1.3.0.ebuild b/app-admin/lastpass-cli/lastpass-cli-1.3.0.ebuild
new file mode 100644
index 000000000000..2c34bdeb3291
--- /dev/null
+++ b/app-admin/lastpass-cli/lastpass-cli-1.3.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils bash-completion-r1
+
+DESCRIPTION="Interfaces with LastPass.com from the command line."
+HOMEPAGE="https://github.com/lastpass/lastpass-cli"
+SRC_URI="https://github.com/lastpass/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2+ GPL-2+-with-openssl-exception"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl X +pinentry test"
+
+RDEPEND="
+ X? ( || ( x11-misc/xclip x11-misc/xsel ) )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ net-misc/curl
+ dev-libs/libxml2
+ pinentry? ( app-crypt/pinentry )
+"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBASH_COMPLETION_COMPLETIONSDIR="$(get_bashcompdir)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile all doc-man $(usex test lpass-test '')
+}
+
+src_install() {
+ cmake-utils_src_install install install-doc
+}
+
+src_test() {
+ local myctestargs=(
+ -j1 # Parallel tests fail
+ )
+
+ # The path to lpass-test is hardcoded to "${S}"/build/lpass-test
+ # which is incorrect for our out-of-source build
+ sed -e "s|TEST_LPASS=.*|TEST_LPASS=\"${BUILD_DIR}/lpass-test\"|" \
+ -i "${S}"/test/include.sh || die
+
+ cmake-utils_src_test
+}