summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2021-05-23 12:24:43 +0200
committerTobias Klausmann <klausman@gentoo.org>2021-05-23 12:24:57 +0200
commit3af99535a1201ea9492e0c1aa54287817dc5ac42 (patch)
treeead666267f80393a3b645d076b5a977f3626cb72 /app-admin/lib_users
parentmedia-sound/klick: py3_9 (diff)
downloadgentoo-3af99535a1201ea9492e0c1aa54287817dc5ac42.tar.gz
gentoo-3af99535a1201ea9492e0c1aa54287817dc5ac42.tar.bz2
gentoo-3af99535a1201ea9492e0c1aa54287817dc5ac42.zip
app-admin/lib_users: Add python 3.10 as compatible version
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Tobias Klausmann <klausman@gentoo.org>
Diffstat (limited to 'app-admin/lib_users')
-rw-r--r--app-admin/lib_users/lib_users-0.14-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-admin/lib_users/lib_users-0.14-r2.ebuild b/app-admin/lib_users/lib_users-0.14-r2.ebuild
new file mode 100644
index 000000000000..6d920f0bbaec
--- /dev/null
+++ b/app-admin/lib_users/lib_users-0.14-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit python-r1
+
+DESCRIPTION="Check for mapped libs and open files that are marked as deleted"
+HOMEPAGE="https://github.com/klausman/lib_users"
+SRC_URI="https://github.com/klausman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${PYTHON_DEPS}"
+
+src_test() {
+ python_foreach_impl nosetests --verbosity=2
+}
+
+my_install() {
+ python_newscript lib_users.py lib_users
+ python_newscript fd_users.py fd_users
+ # lib_users_util/ contains a test script we don't want, so do things by hand
+ python_moduleinto lib_users_util
+ python_domodule lib_users_util/common.py
+ python_domodule lib_users_util/__init__.py
+}
+
+src_install() {
+ python_foreach_impl my_install
+ dodoc README.md TODO
+}