summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2018-07-11 10:27:01 +0200
committerTobias Klausmann <klausman@gentoo.org>2018-07-11 10:27:43 +0200
commit8f9880fc5514b9e4af205c5a4906c1170f4ecce5 (patch)
tree14e409bf112093790c794b35422b2182880e8778 /app-admin/lib_users
parentsys-apps/onerng: New package (diff)
downloadgentoo-8f9880fc5514b9e4af205c5a4906c1170f4ecce5.tar.gz
gentoo-8f9880fc5514b9e4af205c5a4906c1170f4ecce5.tar.bz2
gentoo-8f9880fc5514b9e4af205c5a4906c1170f4ecce5.zip
app-admin/lib_users: Add v0.11
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'app-admin/lib_users')
-rw-r--r--app-admin/lib_users/Manifest1
-rw-r--r--app-admin/lib_users/lib_users-0.11.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-admin/lib_users/Manifest b/app-admin/lib_users/Manifest
index 4ba224f31271..d2bcc06986cb 100644
--- a/app-admin/lib_users/Manifest
+++ b/app-admin/lib_users/Manifest
@@ -1 +1,2 @@
DIST lib_users-0.10.tar.gz 25636 BLAKE2B 6e660b80ef75f71d47f4783dc741e8b0c17f3cfe31296c5624adcfed5836a0b86964f042eafb5b34e259a824c79efb537558d625bc16d07fb388d61ece7c6329 SHA512 dee8203457570f686df69dc91d71614b462845c848a3445fd9b9f94047fdba8171cc2555fa4299bc4c361905d488c1f17cee4ab0e99899f37995377d6011805a
+DIST lib_users-0.11.tar.gz 25660 BLAKE2B 8f5a827840d4074a0e8abd77e43f60eb09f199f58a2bde0c2bce7613d6ba1d9b12dd46adffa528ff351f54933c304f274abef9c35550d7af3519101dcec69d0a SHA512 a54fc8f57cffcd08e77e86eaf50ec6e68e45e1e9458e25e035af90e14be13980a400c4d264f70ef67e141e1d54581b0487b2b70dd084dc5840424221b46f644a
diff --git a/app-admin/lib_users/lib_users-0.11.ebuild b/app-admin/lib_users/lib_users-0.11.ebuild
new file mode 100644
index 000000000000..32a7d7827f37
--- /dev/null
+++ b/app-admin/lib_users/lib_users-0.11.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit python-r1
+
+DESCRIPTION="Check for mapped libs and open files that are marked as deleted"
+HOMEPAGE="https://github.com/klausman/lib_users"
+SRC_URI="https://github.com/klausman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${PYTHON_DEPS}"
+
+src_test() {
+ python_foreach_impl nosetests --verbosity=2
+}
+
+my_install() {
+ python_newscript lib_users.py lib_users
+ python_newscript fd_users.py fd_users
+ # lib_users_util/ contains a test script we don't want, so do things by hand
+ python_moduleinto lib_users_util
+ python_domodule lib_users_util/common.py
+ python_domodule lib_users_util/__init__.py
+}
+
+src_install() {
+ python_foreach_impl my_install
+ dodoc README.md TODO
+}