summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-03-19 03:10:46 -0400
committerTim Harder <radhermit@gentoo.org>2018-03-19 03:12:47 -0400
commitc73717846b0e4ce5964054143e267eea3f2eb146 (patch)
tree533cb5dcea4834e2d840358d534fbb3a217ef01e /app-admin/lnav/lnav-0.8.3.ebuild
parentdev-scheme/slib: x86 stable wrt bug #646760 (diff)
downloadgentoo-c73717846b0e4ce5964054143e267eea3f2eb146.tar.gz
gentoo-c73717846b0e4ce5964054143e267eea3f2eb146.tar.bz2
gentoo-c73717846b0e4ce5964054143e267eea3f2eb146.zip
app-admin/lnav: version bump to 0.8.3
Diffstat (limited to 'app-admin/lnav/lnav-0.8.3.ebuild')
-rw-r--r--app-admin/lnav/lnav-0.8.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-admin/lnav/lnav-0.8.3.ebuild b/app-admin/lnav/lnav-0.8.3.ebuild
new file mode 100644
index 000000000000..5a47db6dfcb1
--- /dev/null
+++ b/app-admin/lnav/lnav-0.8.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs autotools
+
+DESCRIPTION="A curses-based tool for viewing and analyzing log files"
+HOMEPAGE="http://lnav.org"
+SRC_URI="https://github.com/tstack/lnav/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="unicode"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-db/sqlite:3
+ dev-libs/libpcre[cxx]
+ >=net-misc/curl-7.23.0
+ sys-libs/ncurses:0=[unicode?]
+ sys-libs/readline:0=
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS NEWS README )
+
+src_prepare() {
+ default
+
+ # skip failing tests
+ sed -i \
+ -e '/test_listview\.sh/d' \
+ -e '/test_view_colors\.sh/d' \
+ -e '/test_sql\.sh/d' \
+ test/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_with unicode ncursesw)
+}