summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/logcheck
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/logcheck')
-rw-r--r--app-admin/logcheck/Manifest3
-rw-r--r--app-admin/logcheck/files/logcheck.cron10
-rw-r--r--app-admin/logcheck/logcheck-1.3.15-r1.ebuild46
-rw-r--r--app-admin/logcheck/logcheck-1.3.15-r2.ebuild52
-rw-r--r--app-admin/logcheck/logcheck-1.3.16.ebuild52
-rw-r--r--app-admin/logcheck/logcheck-1.3.17.ebuild52
-rw-r--r--app-admin/logcheck/metadata.xml8
7 files changed, 223 insertions, 0 deletions
diff --git a/app-admin/logcheck/Manifest b/app-admin/logcheck/Manifest
new file mode 100644
index 000000000000..20cabea3f255
--- /dev/null
+++ b/app-admin/logcheck/Manifest
@@ -0,0 +1,3 @@
+DIST logcheck_1.3.15.tar.gz 162397 SHA256 b29b4753940a9130b5f19f60d2d89af23be220674625f4bd2fb1d40945d0b9e5 SHA512 45c9e779fc1d1f417aea3f02e70eff4dbc7cd0b45e04f7efc458a4552866686cbb095d0b5ebaf32a57d423a3753b4573277a464f5539789350b087569e025abf WHIRLPOOL 7d4c1975453427eb0897b9f05670565643fd36c44204b23470adf1eac17b19ec77aaeae3523b7b1844f20acf39da0d736386b80bfc0f4059c2099ff816ddd08c
+DIST logcheck_1.3.16.tar.xz 131832 SHA256 3eea6f4d25b5cba59d30b8edd35e392389b8e4966d0aceac11c220e98426b8e6 SHA512 1dca1c571e01b2816b7d8ac7a7b5b7e4e250b8c298299c707d86e3c18bd0583b1afd72ff80e8ff98259be5eb46b719ce1e5b97377f42a1982ff292c5a92569c4 WHIRLPOOL 85d25f871dc0e31a49d518e292041b98b989957f778bd74a62aac331e1672cd5f1a346de41174f9377ee930a590faf04736f51eb5c6d6b404e22642572aa54d3
+DIST logcheck_1.3.17.tar.xz 130956 SHA256 c2d3fc323e8c6555e91d956385dbfd0f67b55872ed0f6a7ad8ad2526a9faf03a SHA512 e4a30b6ccd7a9f0f51354b1a6e577f6a3837e3db078f61b3d3ceaf630a1f1eeae03324e6ec58307f8f723dbd017e1543c15f7dc34e50c0eeb9ee0b160b2c879d WHIRLPOOL 21db3f57a07cf416a313ccdb393233c47e30c3675870d7fc1b6024eaa54db6df3542a7d3f40d6fc5c3174593cd910efbac71cd86b1865f969e8ca6dd0523e217
diff --git a/app-admin/logcheck/files/logcheck.cron b/app-admin/logcheck/files/logcheck.cron
new file mode 100644
index 000000000000..3b3f4fcf62bd
--- /dev/null
+++ b/app-admin/logcheck/files/logcheck.cron
@@ -0,0 +1,10 @@
+#!/bin/bash
+
+set -e
+
+if [ ! -d /var/lock/logcheck ]; then
+ mkdir -p /var/lock/logcheck
+fi
+chown -R logcheck:logcheck /var/lock/logcheck
+
+su -s /bin/bash -c /usr/sbin/logcheck logcheck
diff --git a/app-admin/logcheck/logcheck-1.3.15-r1.ebuild b/app-admin/logcheck/logcheck-1.3.15-r1.ebuild
new file mode 100644
index 000000000000..9d135618f12d
--- /dev/null
+++ b/app-admin/logcheck/logcheck-1.3.15-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit user
+
+DESCRIPTION="Mails anomalies in the system logfiles to the administrator"
+HOMEPAGE="http://packages.debian.org/sid/logcheck"
+SRC_URI="mirror://debian/pool/main/l/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!app-admin/logsentry
+ app-misc/lockfile-progs
+ dev-lang/perl
+ dev-perl/mime-construct
+ virtual/mailx
+ ${DEPEND}"
+
+pkg_setup() {
+ enewgroup logcheck
+ enewuser logcheck -1 -1 -1 logcheck
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ keepdir /var/lib/logcheck
+ dodoc AUTHORS CHANGES CREDITS TODO docs/README.*
+ doman docs/logtail.8 docs/logtail2.8
+
+ exeinto /etc/cron.hourly
+ doexe "${FILESDIR}/${PN}.cron"
+}
+
+pkg_postinst() {
+ chown -R logcheck:logcheck /etc/logcheck /var/lib/logcheck || die
+
+ elog "Please read the guide ad http://www.gentoo.org/doc/en/logcheck.xml"
+ elog "for installation instructions."
+}
diff --git a/app-admin/logcheck/logcheck-1.3.15-r2.ebuild b/app-admin/logcheck/logcheck-1.3.15-r2.ebuild
new file mode 100644
index 000000000000..b8e1b1d47fbb
--- /dev/null
+++ b/app-admin/logcheck/logcheck-1.3.15-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit user
+
+DESCRIPTION="Mails anomalies in the system logfiles to the administrator"
+HOMEPAGE="http://packages.debian.org/sid/logcheck"
+SRC_URI="mirror://debian/pool/main/l/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!app-admin/logsentry
+ app-misc/lockfile-progs
+ dev-lang/perl
+ dev-perl/mime-construct
+ virtual/mailx
+ ${DEPEND}"
+
+pkg_setup() {
+ enewgroup logcheck
+ enewuser logcheck -1 -1 -1 logcheck
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # Do not install /var/lock, bug #449968 . Use rmdir to make sure
+ # the directories removed are empty.
+ rmdir "${D}/var/lock/logcheck" || die
+ rmdir "${D}/var/lock" || die
+
+ keepdir /var/lib/logcheck
+ dodoc AUTHORS CHANGES CREDITS TODO docs/README.*
+ doman docs/logtail.8 docs/logtail2.8
+
+ exeinto /etc/cron.hourly
+ doexe "${FILESDIR}/${PN}.cron"
+}
+
+pkg_postinst() {
+ chown -R logcheck:logcheck /etc/logcheck /var/lib/logcheck || die
+
+ elog "Please read the guide ad http://www.gentoo.org/doc/en/logcheck.xml"
+ elog "for installation instructions."
+}
diff --git a/app-admin/logcheck/logcheck-1.3.16.ebuild b/app-admin/logcheck/logcheck-1.3.16.ebuild
new file mode 100644
index 000000000000..8d23d6d9fada
--- /dev/null
+++ b/app-admin/logcheck/logcheck-1.3.16.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit user
+
+DESCRIPTION="Mails anomalies in the system logfiles to the administrator"
+HOMEPAGE="http://packages.debian.org/sid/logcheck"
+SRC_URI="mirror://debian/pool/main/l/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!app-admin/logsentry
+ app-misc/lockfile-progs
+ dev-lang/perl
+ dev-perl/mime-construct
+ virtual/mailx
+ ${DEPEND}"
+
+pkg_setup() {
+ enewgroup logcheck
+ enewuser logcheck -1 -1 -1 logcheck
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # Do not install /var/lock, bug #449968 . Use rmdir to make sure
+ # the directories removed are empty.
+ rmdir "${D}/var/lock/logcheck" || die
+ rmdir "${D}/var/lock" || die
+
+ keepdir /var/lib/logcheck
+ dodoc AUTHORS CHANGES CREDITS TODO docs/README.*
+ doman docs/logtail.8 docs/logtail2.8
+
+ exeinto /etc/cron.hourly
+ doexe "${FILESDIR}/${PN}.cron"
+}
+
+pkg_postinst() {
+ chown -R logcheck:logcheck /etc/logcheck /var/lib/logcheck || die
+
+ elog "Please read the guide ad http://www.gentoo.org/doc/en/logcheck.xml"
+ elog "for installation instructions."
+}
diff --git a/app-admin/logcheck/logcheck-1.3.17.ebuild b/app-admin/logcheck/logcheck-1.3.17.ebuild
new file mode 100644
index 000000000000..50f0fc71c2f8
--- /dev/null
+++ b/app-admin/logcheck/logcheck-1.3.17.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit user
+
+DESCRIPTION="Mails anomalies in the system logfiles to the administrator"
+HOMEPAGE="http://packages.debian.org/sid/logcheck"
+SRC_URI="mirror://debian/pool/main/l/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!app-admin/logsentry
+ app-misc/lockfile-progs
+ dev-lang/perl
+ dev-perl/mime-construct
+ virtual/mailx
+ ${DEPEND}"
+
+pkg_setup() {
+ enewgroup logcheck
+ enewuser logcheck -1 -1 -1 logcheck
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # Do not install /var/lock, bug #449968 . Use rmdir to make sure
+ # the directories removed are empty.
+ rmdir "${D}/var/lock/logcheck" || die
+ rmdir "${D}/var/lock" || die
+
+ keepdir /var/lib/logcheck
+ dodoc AUTHORS CHANGES CREDITS TODO docs/README.*
+ doman docs/logtail.8 docs/logtail2.8
+
+ exeinto /etc/cron.hourly
+ doexe "${FILESDIR}/${PN}.cron"
+}
+
+pkg_postinst() {
+ chown -R logcheck:logcheck /etc/logcheck /var/lib/logcheck || die
+
+ elog "Please read the guide ad http://www.gentoo.org/doc/en/logcheck.xml"
+ elog "for installation instructions."
+}
diff --git a/app-admin/logcheck/metadata.xml b/app-admin/logcheck/metadata.xml
new file mode 100644
index 000000000000..d047926ffe02
--- /dev/null
+++ b/app-admin/logcheck/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>phajdan.jr@gentoo.org</email>
+ <name>Pawel Hajdan jr</name>
+ </maintainer>
+</pkgmetadata>