summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2016-07-30 09:45:38 -0400
committerZero_Chaos <zerochaos@gentoo.org>2016-07-30 09:45:38 -0400
commit6e9cb53063b102e2c3a2e9c198693ae11d5d86c6 (patch)
tree7835866a37d0977305f1d8e3fb20ce0cc7ee8230 /app-admin/logrotate/logrotate-3.9.2-r2.ebuild
parentapp-admin/logrotate: simple safe sed line to fix bug 589854 (diff)
downloadgentoo-6e9cb53063b102e2c3a2e9c198693ae11d5d86c6.tar.gz
gentoo-6e9cb53063b102e2c3a2e9c198693ae11d5d86c6.tar.bz2
gentoo-6e9cb53063b102e2c3a2e9c198693ae11d5d86c6.zip
app-admin/logrotate: ha, while trying to fix the same bug floppym reminded me to bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-admin/logrotate/logrotate-3.9.2-r2.ebuild')
-rw-r--r--app-admin/logrotate/logrotate-3.9.2-r2.ebuild87
1 files changed, 87 insertions, 0 deletions
diff --git a/app-admin/logrotate/logrotate-3.9.2-r2.ebuild b/app-admin/logrotate/logrotate-3.9.2-r2.ebuild
new file mode 100644
index 000000000000..60b8363956eb
--- /dev/null
+++ b/app-admin/logrotate/logrotate-3.9.2-r2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Rotates, compresses, and mails system logs"
+HOMEPAGE="https://fedorahosted.org/logrotate/"
+SRC_URI="https://github.com/logrotate/logrotate/archive/${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="acl +cron selinux"
+
+CDEPEND="
+ >=dev-libs/popt-1.5
+ selinux? (
+ sys-libs/libselinux
+ )
+ acl? ( virtual/acl )"
+
+DEPEND="${CDEPEND}
+ >=sys-apps/sed-4"
+
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-logrotate )
+ cron? ( virtual/cron )"
+
+install_cron_file() {
+ sed -i 's#/usr/sbin/logrotate#/usr/bin/logrotate#' "${S}"/examples/logrotate.cron
+ exeinto /etc/cron.daily
+ newexe "${S}"/examples/logrotate.cron "${PN}"
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-ignore-hidden.patch \
+ "${FILESDIR}"/${P}-fbsd.patch \
+ "${FILESDIR}"/${P}-noasprintf.patch \
+ "${FILESDIR}"/${P}-atomic-create.patch \
+ "${FILESDIR}"/${P}-Werror.patch \
+ "${FILESDIR}"/${P}-lfs.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with acl) $(use_with selinux)
+}
+
+src_compile() {
+ emake ${myconf} RPM_OPT_FLAGS="${CFLAGS}"
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ insinto /usr
+ dobin logrotate
+ doman logrotate.8
+ dodoc CHANGES examples/logrotate*
+
+ insinto /etc
+ doins "${FILESDIR}"/logrotate.conf
+
+ use cron && install_cron_file
+
+ keepdir /etc/logrotate.d
+}
+
+pkg_postinst() {
+ elog "The ${PN} binary is now installed under /usr/bin. Please"
+ elog "update your links"
+ elog
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "If you wish to have logrotate e-mail you updates, please"
+ elog "emerge virtual/mailx and configure logrotate in"
+ elog "/etc/logrotate.conf appropriately"
+ elog
+ elog "Additionally, /etc/logrotate.conf may need to be modified"
+ elog "for your particular needs. See man logrotate for details."
+ fi
+}