summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/mate-system-tools/mate-system-tools-1.8.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/mate-system-tools/mate-system-tools-1.8.1.ebuild')
-rw-r--r--app-admin/mate-system-tools/mate-system-tools-1.8.1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-admin/mate-system-tools/mate-system-tools-1.8.1.ebuild b/app-admin/mate-system-tools/mate-system-tools-1.8.1.ebuild
new file mode 100644
index 000000000000..2fcb75e97826
--- /dev/null
+++ b/app-admin/mate-system-tools/mate-system-tools-1.8.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="Tools aimed to make easy the administration of UNIX systems"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="caja nfs policykit samba"
+
+RDEPEND="app-text/rarian:0
+ >=app-admin/system-tools-backends-2.10.1:0
+ dev-libs/atk:0
+ dev-libs/dbus-glib:0
+ >=dev-libs/glib-2.25.3:2
+ >=dev-libs/liboobs-1.1:0
+ >=sys-apps/dbus-0.32:0
+ net-wireless/wireless-tools:0
+ sys-libs/cracklib:0
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango:0
+ >=x11-libs/gtk+-2.19.7:2
+ virtual/libintl:0
+ caja? ( >=mate-base/caja-1.8:0 )
+ nfs? ( net-fs/nfs-utils:0 )
+ policykit? (
+ >=mate-extra/mate-polkit-1.8:0
+ >=sys-auth/polkit-0.92:0
+ )
+ samba? ( >=net-fs/samba-3:0 )"
+
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools:0
+ sys-devel/gettext:*
+ virtual/pkgconfig:*
+ >=dev-util/intltool-0.35.0:*"
+
+src_configure() {
+ local myconf
+ if ! use nfs && ! use samba; then
+ myconf="--disable-shares"
+ fi
+
+ gnome2_src_configure \
+ ${myconf} \
+ --disable-static \
+ $(use_enable policykit polkit-gtk-mate) \
+ $(use_enable caja)
+}
+
+DOCS="AUTHORS BUGS ChangeLog HACKING NEWS README TODO"