summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-08-15 01:00:34 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-08-15 01:00:34 +0200
commit03f640f7556b6e13f97e8e9eb1bd8678f5437700 (patch)
tree430ebda8c9889f35686ad3502b7f0f0d32be94fd /app-admin/mcelog/mcelog-122.ebuild
parentapp-admin/mcelog: rm old (diff)
downloadgentoo-03f640f7556b6e13f97e8e9eb1bd8678f5437700.tar.gz
gentoo-03f640f7556b6e13f97e8e9eb1bd8678f5437700.tar.bz2
gentoo-03f640f7556b6e13f97e8e9eb1bd8678f5437700.zip
app-admin/mcelog: version bump to 122
Diffstat (limited to 'app-admin/mcelog/mcelog-122.ebuild')
-rw-r--r--app-admin/mcelog/mcelog-122.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-admin/mcelog/mcelog-122.ebuild b/app-admin/mcelog/mcelog-122.ebuild
new file mode 100644
index 000000000000..f46ca0c96188
--- /dev/null
+++ b/app-admin/mcelog/mcelog-122.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info eutils systemd toolchain-funcs
+
+DESCRIPTION="A tool to log and decode Machine Check Exceptions"
+HOMEPAGE="http://mcelog.org/"
+SRC_URI="https://github.com/andikleen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-mcelog )"
+
+CONFIG_CHECK="~X86_MCE"
+
+# TODO: add mce-inject to the tree to support test phase
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.8_pre1-timestamp-${PN}.patch \
+ "${FILESDIR}"/${PN}-1.0_pre3_p20120918-build.patch \
+ "${FILESDIR}"/${PN}-1.0_pre3_p20120918-bashism.patch
+ tc-export CC
+}
+
+src_install() {
+ default
+
+ insinto /etc/cron.daily
+ newins ${PN}.cron ${PN}
+
+ insinto /etc/logrotate.d/
+ newins ${PN}.logrotate ${PN}
+
+ newinitd "${FILESDIR}"/${PN}.init-r1 ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ dodoc *.pdf
+}
+
+pkg_postinst() {
+ einfo "The default configuration set is now installed in /etc/${PN}"
+ einfo "you might want to edit those files."
+ einfo
+ einfo "A sample cronjob is installed into /etc/cron.daily"
+ einfo "without executable bit (system service is the preferred method now)"
+}