summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2017-07-07 14:28:43 +0200
committerUltrabug <ultrabug@gentoo.org>2017-07-31 14:14:05 +0200
commit4286e6a34d2796f5d7b3b8491cbecf1956441026 (patch)
tree10ab63b166538ba211b9ce8e6f076196326a6b1c /app-admin/mongo-tools
parentdev-db/mongodb: bump to 3.0.15 and 3.2.15 (diff)
downloadgentoo-4286e6a34d2796f5d7b3b8491cbecf1956441026.tar.gz
gentoo-4286e6a34d2796f5d7b3b8491cbecf1956441026.tar.bz2
gentoo-4286e6a34d2796f5d7b3b8491cbecf1956441026.zip
app-admin/mongo-tools: bump to 3.4.6
Package-Manager: Portage-2.3.6, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/5062
Diffstat (limited to 'app-admin/mongo-tools')
-rw-r--r--app-admin/mongo-tools/Manifest1
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.4.6.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-admin/mongo-tools/Manifest b/app-admin/mongo-tools/Manifest
index e399c6b39ebb..8106c5289d53 100644
--- a/app-admin/mongo-tools/Manifest
+++ b/app-admin/mongo-tools/Manifest
@@ -5,3 +5,4 @@ DIST mongo-tools-3.2.13.tar.gz 2712076 SHA256 a855eb0141445e34ff3b01807b01646751
DIST mongo-tools-3.2.15.tar.gz 2712102 SHA256 d2f69303037810b9f1785aece94e62cff71e20a07edacf4d477a40b4b9b7a390 SHA512 76a77564825eae547f85ead374050f3b9a29c3cd775bc86a452ba42ee843dbc800805340232094167e288a59d9592db3fe8aeba83ccbaae41196674781476220 WHIRLPOOL 66a2bac4edf113017826b55958c970e4abb946aeb3449f330eb157e3bb76fb8f5a2892e3f6323e0a27dc6f439015d7c02b303dc6a08c2d99680f65f8b4888e2a
DIST mongo-tools-3.4.3.tar.gz 4700637 SHA256 70348800ca4cc04a319ca414291d5359e7dc86c888bc8264045fbc4de00adab2 SHA512 ec754e8b19c517d9603e0eb89cc315e0af53886b74a905c0742faf5369af8b87b84cedf57aaa25f93068cd21370fa8a274a97dc3c58bbb4a50db6c2e4f0109d9 WHIRLPOOL 0b85fcdb52d5f08624bbcedb96d66c8a519e6415b9aefe68e7957627f3f1e220ca1174ea0a037f53ef2de0e594793ab42d6ec7db9cb42aa09b1892500dac5dd5
DIST mongo-tools-3.4.4.tar.gz 4700326 SHA256 d14f4ce153aec373459c802e5a159661ccfde4e5df39d8d750586bae54896cdd SHA512 d49243e41bf3144264add3766a6f7016a07509a583a7368a639d85d2305500dd5afcfbc4449f3dcc8bec6e88bfb76ce021c813fe14169e3bd2476ed0db7c2d5d WHIRLPOOL 33cb527ce7df19e92871219aef9b38f16ae292a4d1cbdd7bb3a1c6ccc752687469b9e4309cc4fd540a65e623740e1ebe20f4bdf8629b50aab25d4ea84c2988cc
+DIST mongo-tools-3.4.6.tar.gz 4715189 SHA256 0b41ee2cb0a3d656f50ad950cc3853b41d5eb77a67ea0eb288f5ac80711ffc1d SHA512 ad1d3acee1969934e8f679d6407b3b55aba85fb99ea806463b7418494fac491ff68033f3e59b55e17276a4d28932c6b74398fffc89ab7c229cf69e5a4714c4a2 WHIRLPOOL 993be475af7b71a189f2b9f7c98e3f49d7ae8d05f99928b242efbd3dd504415394c7c812c4debed192ca0a856f16f9839dc771be8efb1db48b3359e48ea48280
diff --git a/app-admin/mongo-tools/mongo-tools-3.4.6.ebuild b/app-admin/mongo-tools/mongo-tools-3.4.6.ebuild
new file mode 100644
index 000000000000..c631cc6fb835
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-3.4.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="http://www.mongodb.org"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sasl ssl libressl"
+
+# Maintainer note:
+# openssl DEPEND constraint, see:
+# https://github.com/mongodb/mongo-tools/issues/11
+
+RDEPEND="!<dev-db/mongodb-3.0.0"
+DEPEND="${RDEPEND}
+ dev-lang/go:=
+ net-libs/libpcap
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -e 's|go build .*|go build -o "bin/$i" -tags "$tags" "$i/main/$i.go"|g' -i build.sh || die
+
+ # ensure we use bash wrt #582906
+ sed -e 's@/bin/sh@/bin/bash@g' -i build.sh || die
+
+ epatch "${FILESDIR}/${PN}-3.2.10-pie.patch"
+}
+
+src_compile() {
+ local myconf
+
+ if use sasl; then
+ myconf="${myconf} sasl"
+ fi
+
+ if use ssl; then
+ myconf="${myconf} ssl"
+ fi
+
+ ./build.sh ${myconf} || die "build failed"
+}
+
+src_install() {
+ dobin bin/*
+}