summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2017-09-05 18:02:12 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-09-21 21:49:58 +0200
commit99753cfc16c5c572a27a1725002c0a4ef0660e49 (patch)
tree6a0504805df608e26924efe07fb1371e71561b1e /app-admin/mongo-tools
parentsci-biology/foldingathome: drop old 7.4.4-r1 ebuild (diff)
downloadgentoo-99753cfc16c5c572a27a1725002c0a4ef0660e49.tar.gz
gentoo-99753cfc16c5c572a27a1725002c0a4ef0660e49.tar.bz2
gentoo-99753cfc16c5c572a27a1725002c0a4ef0660e49.zip
app-admin/mongo-tools: version bump to 3.4.7.
Package-Manager: Portage-2.3.8, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/5527
Diffstat (limited to 'app-admin/mongo-tools')
-rw-r--r--app-admin/mongo-tools/Manifest1
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.4.7.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-admin/mongo-tools/Manifest b/app-admin/mongo-tools/Manifest
index c998423a2950..30200dd8f63a 100644
--- a/app-admin/mongo-tools/Manifest
+++ b/app-admin/mongo-tools/Manifest
@@ -6,3 +6,4 @@ DIST mongo-tools-3.2.16.tar.gz 2720003 SHA256 1cd699f0e45b0b3afb0cfc7014258fb69e
DIST mongo-tools-3.4.3.tar.gz 4700637 SHA256 70348800ca4cc04a319ca414291d5359e7dc86c888bc8264045fbc4de00adab2 SHA512 ec754e8b19c517d9603e0eb89cc315e0af53886b74a905c0742faf5369af8b87b84cedf57aaa25f93068cd21370fa8a274a97dc3c58bbb4a50db6c2e4f0109d9 WHIRLPOOL 0b85fcdb52d5f08624bbcedb96d66c8a519e6415b9aefe68e7957627f3f1e220ca1174ea0a037f53ef2de0e594793ab42d6ec7db9cb42aa09b1892500dac5dd5
DIST mongo-tools-3.4.4.tar.gz 4700326 SHA256 d14f4ce153aec373459c802e5a159661ccfde4e5df39d8d750586bae54896cdd SHA512 d49243e41bf3144264add3766a6f7016a07509a583a7368a639d85d2305500dd5afcfbc4449f3dcc8bec6e88bfb76ce021c813fe14169e3bd2476ed0db7c2d5d WHIRLPOOL 33cb527ce7df19e92871219aef9b38f16ae292a4d1cbdd7bb3a1c6ccc752687469b9e4309cc4fd540a65e623740e1ebe20f4bdf8629b50aab25d4ea84c2988cc
DIST mongo-tools-3.4.6.tar.gz 4715189 SHA256 0b41ee2cb0a3d656f50ad950cc3853b41d5eb77a67ea0eb288f5ac80711ffc1d SHA512 ad1d3acee1969934e8f679d6407b3b55aba85fb99ea806463b7418494fac491ff68033f3e59b55e17276a4d28932c6b74398fffc89ab7c229cf69e5a4714c4a2 WHIRLPOOL 993be475af7b71a189f2b9f7c98e3f49d7ae8d05f99928b242efbd3dd504415394c7c812c4debed192ca0a856f16f9839dc771be8efb1db48b3359e48ea48280
+DIST mongo-tools-3.4.7.tar.gz 4719382 SHA256 f7a7b014ad2947c0fa4d6973a669f53e8c1af29df7e8bc6daf879b1456c90ce1 SHA512 4ccc77c858f88f57f6b29bfc56361efc3362782fe82e8d73474202ca02c0cad49134f622dcc36cba669b37ac19e869cc76e07254a9eb26e9c175f8bad104a07d WHIRLPOOL 0456ccba63331496bbb8b90ce3e2ef07de97376225ffc547e598a2699d41ad5ddd23de26633a013f38d36945f89cb69fe79b930f77db00956a8ccc2d392f50dc
diff --git a/app-admin/mongo-tools/mongo-tools-3.4.7.ebuild b/app-admin/mongo-tools/mongo-tools-3.4.7.ebuild
new file mode 100644
index 000000000000..eb6528eb5fb8
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-3.4.7.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="https://www.mongodb.org"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sasl ssl libressl"
+
+# Maintainer note:
+# openssl DEPEND constraint, see:
+# https://github.com/mongodb/mongo-tools/issues/11
+
+RDEPEND="!<dev-db/mongodb-3.0.0"
+DEPEND="${RDEPEND}
+ dev-lang/go:=
+ net-libs/libpcap
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # do not substitute version because it uses git
+ sed -i '/^sed/,+3d' build.sh || die
+ sed -i '/^mv/d' build.sh || die
+
+ # build pie to avoid text relocations wrt #582854
+ sed -i 's/go build/go build -buildmode=pie/g' build.sh || die
+
+ # ensure we use bash wrt #582906
+ sed -i 's@/bin/sh@/bin/bash@g' build.sh || die
+
+ default
+}
+
+src_compile() {
+ declare -a myconf
+
+ if use sasl; then
+ myconf+=(sasl)
+ fi
+
+ if use ssl; then
+ myconf+=(ssl)
+ fi
+
+ ./build.sh ${myconf[@]} || die "build failed"
+}
+
+src_install() {
+ dobin bin/*
+}