summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@integralblue.com>2016-07-09 21:36:42 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2016-07-13 21:25:04 -0400
commit89608b1c031f38cf19a2bc21212b854eb33d431d (patch)
treed9fa2f77e9ba01cec1c9b220b6f438f2e268221e /app-admin/needrestart/needrestart-2.8-r1.ebuild
parentapp-admin/needrestart: correct the license to GPL-2+ (diff)
downloadgentoo-89608b1c031f38cf19a2bc21212b854eb33d431d.tar.gz
gentoo-89608b1c031f38cf19a2bc21212b854eb33d431d.tar.bz2
gentoo-89608b1c031f38cf19a2bc21212b854eb33d431d.zip
app-admin/needrestart: fix dependencies
needrestart installs and uses scripts that call sed with '-z' option: https://github.com/liske/needrestart/blob/1a3b68a38e0691ca82e894ef591b23af666cc14d/lib/notify.d.sh#L34 https://github.com/liske/needrestart/blob/1c17aa96ed455c6f10b496fa6a5c17daf96558ac/ex/notify.d/400-notify-send#L34 This option was introduced in sed-4.2.2: http://article.gmane.org/gmane.comp.lang.smalltalk.gnu.general/7873 Thus needrestart must depend on >=sys-apps/sed-4.2.2. needrestart needs sys-devel/gettext to build so add that dependency. needrestart depends on dev-perl/TermReadKey so add that runtime dependency. needrestart does not depend on dev-perl/Term-ProgressBar-Simple so remove that dependency. Gentoo-bug: 588416
Diffstat (limited to 'app-admin/needrestart/needrestart-2.8-r1.ebuild')
-rw-r--r--app-admin/needrestart/needrestart-2.8-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-admin/needrestart/needrestart-2.8-r1.ebuild b/app-admin/needrestart/needrestart-2.8-r1.ebuild
new file mode 100644
index 000000000000..5ac517696326
--- /dev/null
+++ b/app-admin/needrestart/needrestart-2.8-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/liske/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/liske/${PN}/archive/v${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Restart daemons after library updates"
+HOMEPAGE="https://fiasko-nw.net/~thomas/tag/needrestart.html https://github.com/liske/needrestart"
+
+SLOT="0"
+LICENSE="GPL-2+"
+
+RDEPEND="
+ >=sys-apps/sed-4.2.2
+ dev-perl/libintl-perl
+ dev-perl/Module-Find
+ dev-perl/Module-ScanDeps
+ dev-perl/Proc-ProcessTable
+ dev-perl/Sort-Naturally
+ dev-perl/TermReadKey
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-parallelmake.patch # https://bugs.gentoo.org/show_bug.cgi?id=588216
+)
+
+src_install() {
+ default
+ doman man/*.1
+ dodoc -r ex
+}