summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-06-24 16:40:30 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-06-24 16:51:41 +0200
commit9afaea59c516acdd05a75d9395e13ee49d69e26d (patch)
treec129e378b36c0ee9b9287d1478fc1a5eaa4744d3 /app-admin/newsyslog/newsyslog-1.1.0.81.ebuild
parentdev-java/cofoja: version bump. (diff)
downloadgentoo-9afaea59c516acdd05a75d9395e13ee49d69e26d.tar.gz
gentoo-9afaea59c516acdd05a75d9395e13ee49d69e26d.tar.bz2
gentoo-9afaea59c516acdd05a75d9395e13ee49d69e26d.zip
app-admin/newsyslog: version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-admin/newsyslog/newsyslog-1.1.0.81.ebuild')
-rw-r--r--app-admin/newsyslog/newsyslog-1.1.0.81.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-admin/newsyslog/newsyslog-1.1.0.81.ebuild b/app-admin/newsyslog/newsyslog-1.1.0.81.ebuild
new file mode 100644
index 000000000000..a52dcc25d1f2
--- /dev/null
+++ b/app-admin/newsyslog/newsyslog-1.1.0.81.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="a highly configurable program for managing and archiving log files"
+HOMEPAGE="http://www.weird.com/~woods/projects/newsyslog.html"
+SRC_URI="http://download.openpkg.org/components/cache/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="sys-apps/groff"
+
+RDEPEND="
+ virtual/cron
+ app-arch/gzip"
+
+PATCHES=( "${FILESDIR}/${P}-html.patch" )
+
+DOCS=( newsyslog.conf AUTHORS ChangeLog INSTALL NEWS ToDo )
+
+src_configure() {
+ local myconf="--with-syslogd_pid=/var/run/syslog.pid"
+
+ has_version 'app-admin/syslog-ng' \
+ && myconf="--with-syslogd_pid=/var/run/syslog-ng.pid"
+
+ econf \
+ --with-gzip \
+ --with-newsyslog_conf=/etc/newsyslog.conf \
+ ${myconf}
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ catmandir="${T}"/dont-install \
+ install
+ einstalldocs
+}