summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2021-09-24 21:34:57 +0000
committerJoonas Niilola <juippis@gentoo.org>2021-10-04 15:32:23 +0300
commitd19cd6d2392bb67452fd7d1f2ef62257dcf70bde (patch)
tree215742d417f0fd4ab4920f0d308539a01aed9aa4 /app-admin/ngxtop
parentdev-libs/pigpio: fix broken Makefile (diff)
downloadgentoo-d19cd6d2392bb67452fd7d1f2ef62257dcf70bde.tar.gz
gentoo-d19cd6d2392bb67452fd7d1f2ef62257dcf70bde.tar.bz2
gentoo-d19cd6d2392bb67452fd7d1f2ef62257dcf70bde.zip
app-admin/ngxtop: add python3.10, remove DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/813291 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-admin/ngxtop')
-rw-r--r--app-admin/ngxtop/ngxtop-0.0.3_pre141201-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/ngxtop/ngxtop-0.0.3_pre141201-r2.ebuild b/app-admin/ngxtop/ngxtop-0.0.3_pre141201-r2.ebuild
new file mode 100644
index 000000000000..e93de604bd55
--- /dev/null
+++ b/app-admin/ngxtop/ngxtop-0.0.3_pre141201-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="real-time metrics for nginx server (and others)"
+HOMEPAGE="https://github.com/lebinh/ngxtop"
+#SRC_URI="https://github.com/lebinh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.0.2-py3.patch )