summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-07-09 18:10:28 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-07-09 18:10:28 -0500
commitb3bae737833853a6a29976d8a3cc0ac172b3eb2c (patch)
treecf9ee990977191ba510dc7cc780ed3225ac5a547 /app-admin/puppet-agent
parentapp-admin/puppet: don't need the experimental flag for puppet5 (diff)
downloadgentoo-b3bae737833853a6a29976d8a3cc0ac172b3eb2c.tar.gz
gentoo-b3bae737833853a6a29976d8a3cc0ac172b3eb2c.tar.bz2
gentoo-b3bae737833853a6a29976d8a3cc0ac172b3eb2c.zip
app-admin/puppet-agent: 5.0.0 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-admin/puppet-agent')
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-5.0.0.ebuild105
2 files changed, 107 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index a039691b664a..e476c7329f48 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -6,3 +6,5 @@ DIST puppet-agent_1.10.4-1xenial_amd64.deb 16157840 SHA256 4e6ec3496e9d30b06b206
DIST puppet-agent_1.10.4-1xenial_i386.deb 16053584 SHA256 ef42df8facaffb47bd926842886b988276111b67a887619873d146c0dee8f55c SHA512 b2e519b2a24f40a8d099b2fa8690a706d9105693affad70e6f38c3b4cc3539044bc805462c45b828147349bfbdc04859e8563fca2588e3fb538de3798df8f262 WHIRLPOOL 51e5faed153d8aa8ee4b1acadc66f8be5e60534faad28cdf37504e91bdbd60441859cb00e2a8746c96c22cd88de3c58c8e188b2abc699758e0c3a02f01d480e8
DIST puppet-agent_1.9.3-1xenial_amd64.deb 16045528 SHA256 db73567754514595b729c299bea34289fbf108282dcc3ca2b2bda8946b1a9b01 SHA512 1142bb008569ebd26e70c89705539eee89ef1d886fee9c18ee19b563ba280c96295a77b30af2c3b149e2e8fb5cd953f55300d3c3bea1d63cb4e6a4c4103a1cfb WHIRLPOOL 193d8ece0997c66f0e0a0c70df6e41243fabbda7bdc944f1c9940476e7cfa01bbff80e739cd5e3b95d4027b8d13b3186823b2035251c57c69a7a2e188c4a5801
DIST puppet-agent_1.9.3-1xenial_i386.deb 16072786 SHA256 eb9476d55cc769608a3b5a3a971a4c005ae1042c0f3f3f5748b14aa40b6251ea SHA512 b9bb7579fc3106b0b701ef2cdac9dc72a5e663b360e7e10816698fed85337c9aa0b77b392353d70682f2cea057d52ebf1c356474e9ec6ccd8e85302d938666af WHIRLPOOL 2acdd44be0fa1665be34f10d3967185acf49388460af6291ac9cb53c7296af78630d82e6c3fce456bdfd7fbd06d1956d9c592ad17dc0f1cf2ee0aa9c008965ef
+DIST puppet-agent_5.0.0-1xenial_amd64.deb 15120014 SHA256 b2983d7a01c056c306e5a5534a9059515b68ff5f72f05dab8a3751fee4276ce4 SHA512 b1255a8db15e6c922d7a102ad3541c496c4fac1cc484e763c6083bb09cbb93db5abf185ea0a39d13d6bee1b18ba53803691d024dbaa64431cda5e9517f3c3c6a WHIRLPOOL 6c36343e5ee50941bab714d0ea8d7b7e7236c78c7f51ede2672b9fe7c883a897fe303d063dce37e411f9b4e89222f7affb38579f72b31ae0d2aa0e2c102be639
+DIST puppet-agent_5.0.0-1xenial_i386.deb 15619584 SHA256 820367b49827855f19d3094d156184c8da2958e00e7dda4a3da37bbac7696cf5 SHA512 9264b1143189c620cbf9dc7ff0b67939427c732c6bf27941a214066dcf88ed6570641a122f243774d01524607361129a777e50fa7b97addf15e9966d7701dee2 WHIRLPOOL 1cafcce45fb1072b8c4ba49192c0bd8da7a7cf60542530626468e12bb11f09fc7568b761403d1f03725c368e73209c0be00c07e5a5a007e9d653ef2e7cd32c41
diff --git a/app-admin/puppet-agent/puppet-agent-5.0.0.ebuild b/app-admin/puppet-agent/puppet-agent-5.0.0.ebuild
new file mode 100644
index 000000000000..135465a8a577
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-5.0.0.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils systemd unpacker user
+
+DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/xenial/puppet5/${PN:0:1}/${PN}/${PN}_${PV}-1xenial"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+ !app-admin/mcollective
+ !app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what"
+
+DEPEND="
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/glibc
+ >=sys-libs/readline-6.0
+ <sys-libs/readline-7.0
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-3.1.0 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="
+ /opt/puppetlabs/puppet
+ /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/mathn/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/io/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/dl/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/racc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/enc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/json/ext/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/rbconfig/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/digest/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/engines/*
+ /opt/puppetlabs/puppet/lib/virt-what/*
+ /opt/puppetlabs/puppet/lib/*
+ /opt/puppetlabs/puppet/bin/*"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/run/puppet puppet
+}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/mcollective
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/mcollective
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ newinitd "${FILESDIR}/mcollective.initd" mcollective
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/mcollective.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym /opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym /opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym /opt/puppetlabs/bin/mco /usr/bin/mco
+ dosym /opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym /opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
+ dosym /opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym /opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+ dosym /opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+ dosym /opt/puppetlabs/puppet/bin/extlookup2hiera /usr/bin/extlookup2hiera
+}