summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-03-07 12:55:54 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-07 12:55:54 +0100
commitd6f77956c627f98ca9151b317834094bd8a364fa (patch)
treedbf4cf3822c4f63512e84be42607f15ed201cbe7 /app-admin/puppet-agent
parentapp-admin/prelude-manager: migrate to tmpfiles.eclass (diff)
downloadgentoo-d6f77956c627f98ca9151b317834094bd8a364fa.tar.gz
gentoo-d6f77956c627f98ca9151b317834094bd8a364fa.tar.bz2
gentoo-d6f77956c627f98ca9151b317834094bd8a364fa.zip
app-admin/puppet-agent: migrate to tmpfiles.eclass
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-admin/puppet-agent')
-rw-r--r--app-admin/puppet-agent/puppet-agent-6.19.1-r1.ebuild6
-rw-r--r--app-admin/puppet-agent/puppet-agent-7.3.0.ebuild4
-rw-r--r--app-admin/puppet-agent/puppet-agent-7.4.0.ebuild4
3 files changed, 7 insertions, 7 deletions
diff --git a/app-admin/puppet-agent/puppet-agent-6.19.1-r1.ebuild b/app-admin/puppet-agent/puppet-agent-6.19.1-r1.ebuild
index 7537a83b6293..650df2144535 100644
--- a/app-admin/puppet-agent/puppet-agent-6.19.1-r1.ebuild
+++ b/app-admin/puppet-agent/puppet-agent-6.19.1-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit eutils systemd unpacker
+inherit eutils systemd unpacker tmpfiles
DESCRIPTION="general puppet client utils along with hiera and facter"
HOMEPAGE="https://puppetlabs.com/"
@@ -64,7 +64,7 @@ src_install() {
newinitd "${FILESDIR}/puppet.initd2" puppet
systemd_dounit lib/systemd/system/puppet.service
systemd_dounit lib/systemd/system/pxp-agent.service
- systemd_newtmpfilesd usr/lib/tmpfiles.d/puppet-agent.conf puppet-agent.conf
+ newtmpfiles usr/lib/tmpfiles.d/puppet-agent.conf puppet-agent.conf
# symlinks
chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
diff --git a/app-admin/puppet-agent/puppet-agent-7.3.0.ebuild b/app-admin/puppet-agent/puppet-agent-7.3.0.ebuild
index c5679f7b83b6..69c3c3eda8ba 100644
--- a/app-admin/puppet-agent/puppet-agent-7.3.0.ebuild
+++ b/app-admin/puppet-agent/puppet-agent-7.3.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit eutils systemd unpacker
+inherit eutils systemd unpacker tmpfiles
DESCRIPTION="general puppet client utils along with hiera and facter"
HOMEPAGE="https://puppetlabs.com/"
@@ -64,7 +64,7 @@ src_install() {
newinitd "${FILESDIR}/puppet.initd2" puppet
systemd_dounit lib/systemd/system/puppet.service
systemd_dounit lib/systemd/system/pxp-agent.service
- systemd_newtmpfilesd usr/lib/tmpfiles.d/puppet-agent.conf puppet-agent.conf
+ newtmpfiles usr/lib/tmpfiles.d/puppet-agent.conf puppet-agent.conf
# symlinks
chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
diff --git a/app-admin/puppet-agent/puppet-agent-7.4.0.ebuild b/app-admin/puppet-agent/puppet-agent-7.4.0.ebuild
index 8a6e3a65de40..d48586e2c6e4 100644
--- a/app-admin/puppet-agent/puppet-agent-7.4.0.ebuild
+++ b/app-admin/puppet-agent/puppet-agent-7.4.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit eutils systemd unpacker
+inherit eutils systemd unpacker tmpfiles
DESCRIPTION="general puppet client utils along with hiera and facter"
HOMEPAGE="https://puppetlabs.com/"
@@ -64,7 +64,7 @@ src_install() {
newinitd "${FILESDIR}/puppet.initd2" puppet
systemd_dounit lib/systemd/system/puppet.service
systemd_dounit lib/systemd/system/pxp-agent.service
- systemd_newtmpfilesd usr/lib/tmpfiles.d/puppet-agent.conf puppet-agent.conf
+ newtmpfiles usr/lib/tmpfiles.d/puppet-agent.conf puppet-agent.conf
# symlinks
chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter