summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-06-01 19:09:28 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-06-01 19:13:20 -0500
commitb4f16ac05ba09d575591f0d9e2879daf77f31205 (patch)
tree7ad073a1d1a5a14af399be91450d4c427d46ce33 /app-admin/puppet
parentdev-db/mysql: fix pkg_config (diff)
downloadgentoo-b4f16ac05ba09d575591f0d9e2879daf77f31205.tar.gz
gentoo-b4f16ac05ba09d575591f0d9e2879daf77f31205.tar.bz2
gentoo-b4f16ac05ba09d575591f0d9e2879daf77f31205.zip
app-admin/puppet: 6.15.0 stable amd64/x86 with cleanup
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/puppet')
-rw-r--r--app-admin/puppet/Manifest1
-rw-r--r--app-admin/puppet/puppet-6.14.0.ebuild136
-rw-r--r--app-admin/puppet/puppet-6.15.0.ebuild2
3 files changed, 1 insertions, 138 deletions
diff --git a/app-admin/puppet/Manifest b/app-admin/puppet/Manifest
index 6502e5527867..ae545332efec 100644
--- a/app-admin/puppet/Manifest
+++ b/app-admin/puppet/Manifest
@@ -1,4 +1,3 @@
DIST puppet-5.5.19.tar.gz 2993740 BLAKE2B aa6bde89489279769ee9a1ed5508fb223f7f0153b1b1991970018908eee70ff0816688c702b8dc779d01e1978ea7f9290c80523648730d5408a17674c11345fd SHA512 996fa155ca04c8c3c96c29cf65cd24eaf9e19e89fcf85345509dbd3673b28c263df5b62d6f016b8ac1c1da8ed86f0acf3100eae2656252bb10c542972db81de3
DIST puppet-5.5.20.tar.gz 2995117 BLAKE2B f147be28967da748bf8d5f7250eae9045caafaa3925f850cc0a77acc19a6a47ed92d4ec81278334608839f6f8c83cab19324f2753bc05d3a042a3bfaccb72a46 SHA512 83b8f234697e13d6fd8ac16634fff4e4adfece70858c32c1001925c71cc4d9a482da1880c27c08e796facb46d5d17889f9521121a69cb49e160e3c031ad564c4
-DIST puppet-6.14.0.tar.gz 2842351 BLAKE2B db9a467d8e0f4f25d45c2f735ee9d11ac6ed4e47c16b95ded3ff9f1c5055ea866735bcda27c19c2988035d9592035e433ef0d79a19781c99f4e97388edf46b93 SHA512 066ad8de6393cb58b1f92fae450dc72dabcbe912cdbb3417848a66955fe17696a68abf67d86b107a2b1c54e7037d38da7264a9234a8833b56065c8e407ff57a4
DIST puppet-6.15.0.tar.gz 2880562 BLAKE2B 082f6a6b0ee56cdb1cd98b8cade8b07b7970ae0a78a9cf7c80e9af945eb722ad156b28004ad565c51750a63fa5932e99b1dd39ac0d4008d3ed225868e7671a31 SHA512 ac7e17bd87ee924fd928d565389b424ff2ed45b9b08e1be4eff4dec3688545657e2dfede46adeb48faecf3875c640c99b07ed6e09906b3e66b4654bb984d9296
diff --git a/app-admin/puppet/puppet-6.14.0.ebuild b/app-admin/puppet/puppet-6.14.0.ebuild
deleted file mode 100644
index 11fd2d3c5085..000000000000
--- a/app-admin/puppet/puppet-6.14.0.ebuild
+++ /dev/null
@@ -1,136 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_TASK_DOC="doc:all"
-
-RUBY_FAKEGEM_EXTRAINSTALL="locales"
-
-inherit eutils ruby-fakegem eapi7-ver
-
-DESCRIPTION="A system automation and configuration management software."
-HOMEPAGE="https://puppet.com/"
-SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 x86"
-IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
-RESTRICT="test"
-
-ruby_add_rdepend "
- dev-ruby/hiera
- dev-ruby/json:=
- dev-ruby/semantic_puppet
- >=dev-ruby/facter-3.0.0
- dev-ruby/concurrent-ruby
- augeas? ( dev-ruby/ruby-augeas )
- diff? ( dev-ruby/diff-lcs )
- doc? ( dev-ruby/rdoc )
- ldap? ( dev-ruby/ruby-ldap )
- shadow? ( dev-ruby/ruby-shadow )
- sqlite? ( dev-ruby/sqlite3 )
- virtual/ruby-ssl
- dev-ruby/hocon"
-
-ruby_add_bdepend "
- doc? ( dev-ruby/yard )
- test? (
- dev-ruby/mocha
- dev-ruby/rack
- dev-ruby/rspec-its
- )"
-# this should go in the above lists, but isn't because of test deps not being keyworded
-# dev-ruby/rspec-collection_matchers
-
-RDEPEND+=" ${RDEPEND}
- rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
- selinux? (
- sys-libs/libselinux[ruby]
- sec-policy/selinux-puppet
- )
- vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
- >=app-portage/eix-0.18.0
- acct-user/puppet
- acct-group/puppet"
-PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
-
-all_ruby_prepare() {
- # Avoid spec that require unpackaged json-schema.
- rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
-
- # can't be run within portage.
- epatch "${FILESDIR}/puppet-fix-tests-6.10.1.patch"
-
- # fix systemd path
- epatch "${FILESDIR}/puppet-systemd.patch"
-
- # Avoid specs that can only run in the puppet.git repository. This
- # should be narrowed down to the specific specs.
- rm spec/integration/parser/compiler_spec.rb || die
-
- # Avoid failing spec that need further investigation.
- rm spec/unit/module_tool/metadata_spec.rb || die
-}
-
-each_ruby_install() {
- each_fakegem_install
-# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- # systemd stuffs
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
-
- # tmpfiles stuff
- insinto /usr/lib/tmpfiles.d
- newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
-
- # openrc init stuff
- newinitd "${FILESDIR}"/puppet.init-4.x puppet
-
- keepdir /etc/puppetlabs/puppet/ssl
-
- keepdir /var/lib/puppet/facts
- keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/lib/puppet
-
- fperms 0750 /var/lib/puppet
-
- fperms 0750 /etc/puppetlabs
- fperms 0750 /etc/puppetlabs/puppet
- fperms 0750 /etc/puppetlabs/puppet/ssl
- fowners -R :puppet /etc/puppetlabs
- fowners -R :puppet /var/lib/puppet
-
- if use ldap ; then
- insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
- fi
-
- # ext and examples files
- for f in $(find ext examples -type f) ; do
- docinto "$(dirname ${f})"; dodoc "${f}"
- done
-}
-
-pkg_postinst() {
- elog
- elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
- elog "cause puppet to hang while installing packages."
- elog
- elog "Portage Puppet module with Gentoo-specific resources:"
- elog "http://forge.puppetlabs.com/gentoo/portage"
- elog
- elog "If updating from puppet 5 to 6, keep in mind that webrick (server/master)"
- elog "suppert was removed for >=6.x, please migrate to puppetserver if you have"
- elog "not already done so."
- elog
-}
diff --git a/app-admin/puppet/puppet-6.15.0.ebuild b/app-admin/puppet/puppet-6.15.0.ebuild
index f50ee1410b08..11fd2d3c5085 100644
--- a/app-admin/puppet/puppet-6.15.0.ebuild
+++ b/app-admin/puppet/puppet-6.15.0.ebuild
@@ -19,7 +19,7 @@ SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
LICENSE="Apache-2.0 GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 x86"
IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
RESTRICT="test"