summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-11-07 20:24:34 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-11-07 20:24:50 +0200
commit9dce1946ac8d694128fd5e871a09c9e5e37a223d (patch)
treeebf6906761a776c1255417c78e15b981232b16b1 /app-admin/radmind
parentdev-python/pymediainfo: bump to 4.3 (diff)
downloadgentoo-9dce1946ac8d694128fd5e871a09c9e5e37a223d.tar.gz
gentoo-9dce1946ac8d694128fd5e871a09c9e5e37a223d.tar.bz2
gentoo-9dce1946ac8d694128fd5e871a09c9e5e37a223d.zip
app-admin/radmind: Apply gcc-10 workaround
Bug: https://bugs.gentoo.org/706556 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'app-admin/radmind')
-rw-r--r--app-admin/radmind/radmind-1.15.1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/app-admin/radmind/radmind-1.15.1.ebuild b/app-admin/radmind/radmind-1.15.1.ebuild
index 3d2decf2a3d7..96807f42abc2 100644
--- a/app-admin/radmind/radmind-1.15.1.ebuild
+++ b/app-admin/radmind/radmind-1.15.1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit flag-o-matic
+
DESCRIPTION="Command-line tools and server to remotely administer multiple Unix filesystems"
HOMEPAGE="https://github.com/Radmind https://sourceforge.net/projects/radmind/"
SRC_URI="https://github.com/voretaq7/radmind/releases/download/${P}/${P}.tar.gz"
@@ -25,6 +27,11 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.14.1-glibc225.patch
)
+src_configure() {
+ append-cflags -fcommon
+ default
+}
+
src_install() {
default
keepdir /var/radmind/{cert,client,postapply,preapply}