summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2021-02-15 18:01:57 +0800
committerYixun Lan <dlan@gentoo.org>2021-02-15 18:02:44 +0800
commit94db90ffa11c41f1c73288402a6bcc51e6021757 (patch)
treec5f43c8c2bb3af8f7ba9600b8687d0cbd5a6f0f5 /app-admin/sshguard
parentdev-libs/xerces-c: EAPI-7 bump, switch to cmake.eclass, for 3.2.3 too (diff)
downloadgentoo-94db90ffa11c41f1c73288402a6bcc51e6021757.tar.gz
gentoo-94db90ffa11c41f1c73288402a6bcc51e6021757.tar.bz2
gentoo-94db90ffa11c41f1c73288402a6bcc51e6021757.zip
app-admin/sshguard: fix live ebuild
merge live version into sole one Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-admin/sshguard')
-rw-r--r--app-admin/sshguard/sshguard-2.4.1-r1.ebuild14
-rw-r--r--app-admin/sshguard/sshguard-99999.ebuild23
2 files changed, 28 insertions, 9 deletions
diff --git a/app-admin/sshguard/sshguard-2.4.1-r1.ebuild b/app-admin/sshguard/sshguard-2.4.1-r1.ebuild
index 7def7a057974..ee4653a215e3 100644
--- a/app-admin/sshguard/sshguard-2.4.1-r1.ebuild
+++ b/app-admin/sshguard/sshguard-2.4.1-r1.ebuild
@@ -3,14 +3,20 @@
EAPI=7
-inherit systemd
+inherit autotools systemd
DESCRIPTION="protects hosts from brute force attacks against ssh"
HOMEPAGE="https://www.sshguard.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+if [[ "${PV}" == 99999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://bitbucket.org/${PN}/${PN}"
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
DEPEND="
sys-devel/flex
@@ -25,6 +31,7 @@ DOCS=(
examples/net.sshguard.plist
examples/whitelistfile.example
)
+
PATCHES=(
"${FILESDIR}"/${PN}-2.4.1-conf.patch
)
@@ -34,6 +41,7 @@ src_prepare() {
sed -i -e "/ExecStartPre/s:/usr/sbin:/sbin:g" \
-e "/ExecStart/s:/usr/local/sbin:/usr/sbin:g" \
"${S}"/examples/${PN}.service || die
+ eautoreconf
}
src_install() {
diff --git a/app-admin/sshguard/sshguard-99999.ebuild b/app-admin/sshguard/sshguard-99999.ebuild
index 0f9a63205b67..ee4653a215e3 100644
--- a/app-admin/sshguard/sshguard-99999.ebuild
+++ b/app-admin/sshguard/sshguard-99999.ebuild
@@ -1,16 +1,22 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools git-r3
+inherit autotools systemd
DESCRIPTION="protects hosts from brute force attacks against ssh"
HOMEPAGE="https://www.sshguard.net/"
-EGIT_REPO_URI="https://bitbucket.org/${PN}/${PN}"
+
+if [[ "${PV}" == 99999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://bitbucket.org/${PN}/${PN}"
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
LICENSE="BSD"
SLOT="0"
-KEYWORDS=""
DEPEND="
sys-devel/flex
@@ -23,15 +29,18 @@ DOCS=(
CONTRIBUTING.rst
README.rst
examples/net.sshguard.plist
- examples/sshguard.service
examples/whitelistfile.example
)
+
PATCHES=(
- "${FILESDIR}"/${PN}-2.1.0-conf.patch
+ "${FILESDIR}"/${PN}-2.4.1-conf.patch
)
src_prepare() {
default
+ sed -i -e "/ExecStartPre/s:/usr/sbin:/sbin:g" \
+ -e "/ExecStart/s:/usr/local/sbin:/usr/sbin:g" \
+ "${S}"/examples/${PN}.service || die
eautoreconf
}
@@ -43,4 +52,6 @@ src_install() {
insinto /etc
newins examples/sshguard.conf.sample sshguard.conf
+
+ systemd_dounit "${S}"/examples/sshguard.service
}