summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-07-02 00:08:43 +0200
committerMichał Górny <mgorny@gentoo.org>2016-07-02 00:09:48 +0200
commitce59a1c91c470fb4313cc319e246251086dfc661 (patch)
tree949c412ca033ecd5f763a48c25d063e713eadd36 /app-admin/systemrescuecd-x86/systemrescuecd-x86-4.8.0.ebuild
parentdev-util/monodevelop: Restore the stable version (diff)
downloadgentoo-ce59a1c91c470fb4313cc319e246251086dfc661.tar.gz
gentoo-ce59a1c91c470fb4313cc319e246251086dfc661.tar.bz2
gentoo-ce59a1c91c470fb4313cc319e246251086dfc661.zip
app-admin/systemrescuecd-x86: Bump to 4.8.0
Diffstat (limited to 'app-admin/systemrescuecd-x86/systemrescuecd-x86-4.8.0.ebuild')
-rw-r--r--app-admin/systemrescuecd-x86/systemrescuecd-x86-4.8.0.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.8.0.ebuild b/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.8.0.ebuild
new file mode 100644
index 000000000000..9ac4ee7db461
--- /dev/null
+++ b/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.8.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="The .iso image of SystemRescueCD rescue disk, x86 (+ amd64) variant"
+HOMEPAGE="http://www.sysresccd.org/"
+SRC_URI="mirror://sourceforge/systemrescuecd/sysresccd-${PN#*-}/${PV}/${P}.iso"
+
+LICENSE="GPL-2"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+isohybrid"
+
+DEPEND="isohybrid? ( >=sys-boot/syslinux-4 )"
+
+S=${WORKDIR}
+
+RESTRICT="mirror"
+
+src_install() {
+ insinto "/usr/share/${PN%-*}"
+ doins "${DISTDIR}/${P}.iso"
+
+ if use isohybrid; then
+ set -- isohybrid -u "${ED}usr/share/${PN%-*}/${P}.iso"
+ echo "${@}"
+ "${@}" || die "${*} failed"
+ fi
+}
+
+pkg_postinst() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # no version newer than ours? we're the newest!
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ ln -f -s -v "${P}.iso" "${f}" || die
+ fi
+}
+
+pkg_postrm() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # if there is no version newer than ours installed
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ # and we are truly and completely uninstalled...
+ if [[ ! ${REPLACED_BY_VERSION} ]]; then
+ # then find an older version to set the symlink to
+ local newest_version=$(best_version "<${CATEGORY}/${PF}")
+
+ if [[ ${newest_version} ]]; then
+ # update the symlink
+ ln -f -s -v "${newest_version%-r*}.iso" "${f}" || die
+ else
+ # last version removed? clean up the symlink
+ rm -v "${f}" || die
+ # and the parent directory
+ rmdir "${f%/*}" || die
+ fi
+ fi
+ fi
+}