summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-01 13:24:13 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-01 13:27:10 +0100
commit3b02f6cb79c855072422d9142f59644e2b0099c4 (patch)
tree25a6ce0808735b4ded0a65b59a656c7e97bc39c6 /app-admin/systemrescuecd-x86/systemrescuecd-x86-4.9.2.ebuild
parentprofiles: Move LIBDIR_* declarations into specific arches (diff)
downloadgentoo-3b02f6cb79c855072422d9142f59644e2b0099c4.tar.gz
gentoo-3b02f6cb79c855072422d9142f59644e2b0099c4.tar.bz2
gentoo-3b02f6cb79c855072422d9142f59644e2b0099c4.zip
app-admin/systemrescuecd-x86: Bump to 4.9.1 & 4.9.2
Diffstat (limited to 'app-admin/systemrescuecd-x86/systemrescuecd-x86-4.9.2.ebuild')
-rw-r--r--app-admin/systemrescuecd-x86/systemrescuecd-x86-4.9.2.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.9.2.ebuild b/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.9.2.ebuild
new file mode 100644
index 000000000000..cb7c7b5a2018
--- /dev/null
+++ b/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.9.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="The .iso image of SystemRescueCD rescue disk, x86 (+ amd64) variant"
+HOMEPAGE="http://www.sysresccd.org/"
+# Large ISO mirroring explicitly approved by infra in bug #588766
+SRC_URI="mirror://sourceforge/systemrescuecd/sysresccd-${PN#*-}/${PV}/${P}.iso"
+
+LICENSE="GPL-2"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+isohybrid"
+
+DEPEND="isohybrid? ( >=sys-boot/syslinux-4 )"
+
+S=${WORKDIR}
+
+src_install() {
+ insinto "/usr/share/${PN%-*}"
+ doins "${DISTDIR}/${P}.iso"
+
+ if use isohybrid; then
+ set -- isohybrid -u "${ED}usr/share/${PN%-*}/${P}.iso"
+ echo "${@}"
+ "${@}" || die "${*} failed"
+ fi
+}
+
+pkg_postinst() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # no version newer than ours? we're the newest!
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ ln -f -s -v "${P}.iso" "${f}" || die
+ fi
+}
+
+pkg_postrm() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # if there is no version newer than ours installed
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ # and we are truly and completely uninstalled...
+ if [[ ! ${REPLACED_BY_VERSION} ]]; then
+ # then find an older version to set the symlink to
+ local newest_version=$(best_version "<${CATEGORY}/${PF}")
+
+ if [[ ${newest_version} ]]; then
+ # update the symlink
+ ln -f -s -v "${newest_version%-r*}.iso" "${f}" || die
+ else
+ # last version removed? clean up the symlink
+ rm -v "${f}" || die
+ # and the parent directory
+ rmdir "${f%/*}" || die
+ fi
+ fi
+ fi
+}