summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-05-04 18:05:59 -0700
committerSam James <sam@gentoo.org>2022-05-07 06:50:25 +0100
commit41d3af34d6ac0b76a8469ba1f657c7299563ddb7 (patch)
tree154599345bac087013e70650078e4480056f5bb1 /app-admin/tpm
parentdev-python/pylint: stable 2.13.5 for hppa, bug #841194 (diff)
downloadgentoo-41d3af34d6ac0b76a8469ba1f657c7299563ddb7.tar.gz
gentoo-41d3af34d6ac0b76a8469ba1f657c7299563ddb7.tar.bz2
gentoo-41d3af34d6ac0b76a8469ba1f657c7299563ddb7.zip
app-admin/tpm: Added
Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/25334 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin/tpm')
-rw-r--r--app-admin/tpm/Manifest1
-rw-r--r--app-admin/tpm/metadata.xml22
-rw-r--r--app-admin/tpm/tpm-1.3.3.ebuild24
-rw-r--r--app-admin/tpm/tpm-9999.ebuild24
4 files changed, 71 insertions, 0 deletions
diff --git a/app-admin/tpm/Manifest b/app-admin/tpm/Manifest
new file mode 100644
index 000000000000..02035e54ae2f
--- /dev/null
+++ b/app-admin/tpm/Manifest
@@ -0,0 +1 @@
+DIST tpm-1.3.3.tar.gz 14623 BLAKE2B efff44b542cc5731c5e2b4527721161e3ad73088eb8ac5f46012dd7da823d67045994f64d830eef48a136fbc4fbb8df04235a10fc9d0e867a8ea2b3a01d1b01e SHA512 113ba21300d2a5fdfb1c058c3f496b004195b68576a832c5ad89b8baecd2d18660ba108e2e7a5ae68148dd60bdaacaee5f5024905b8fc07184a577e0837ae204
diff --git a/app-admin/tpm/metadata.xml b/app-admin/tpm/metadata.xml
new file mode 100644
index 000000000000..a9f6a813f283
--- /dev/null
+++ b/app-admin/tpm/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>orbea@riseup.net</email>
+ <name>orbea</name>
+ </maintainer>
+ <maintainer type="person" proxied="proxy">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <longdescription>
+ tpm is a tiny shell script which is heavily inspired and
+ largely compatible with pass(1). Just like pass it uses
+ gpg2(1) to securely store your passwords, the major difference
+ between pass and tpm is that the latter is a lot more minimal.
+ Furthermore, tpm is written entirely in POSIX shell.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">nmeum/tpm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/tpm/tpm-1.3.3.ebuild b/app-admin/tpm/tpm-1.3.3.ebuild
new file mode 100644
index 000000000000..dd2b55edef2e
--- /dev/null
+++ b/app-admin/tpm/tpm-1.3.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Tiny password manager"
+HOMEPAGE="https://github.com/nmeum/tpm"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/nmeum/${PN}.git"
+else
+ SRC_URI="https://github.com/nmeum/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="app-crypt/gnupg"
+BDEPEND="dev-lang/perl"
+
+src_install() {
+ emake install DESTDIR="${D}" PREFIX="${EPREFIX}/usr"
+}
diff --git a/app-admin/tpm/tpm-9999.ebuild b/app-admin/tpm/tpm-9999.ebuild
new file mode 100644
index 000000000000..dd2b55edef2e
--- /dev/null
+++ b/app-admin/tpm/tpm-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Tiny password manager"
+HOMEPAGE="https://github.com/nmeum/tpm"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/nmeum/${PN}.git"
+else
+ SRC_URI="https://github.com/nmeum/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="app-crypt/gnupg"
+BDEPEND="dev-lang/perl"
+
+src_install() {
+ emake install DESTDIR="${D}" PREFIX="${EPREFIX}/usr"
+}