summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-01-22 22:48:35 -0800
committerZac Medico <zmedico@gentoo.org>2016-01-22 22:48:35 -0800
commitb59b7f4c09821fe30584c5c7ca9ff3abf64d4133 (patch)
treeffa52877b77ae93bb8cadabe345dbc27c2e08e7c /app-admin/vault
parentapp-admin/consul-template: remove old version (diff)
downloadgentoo-b59b7f4c09821fe30584c5c7ca9ff3abf64d4133.tar.gz
gentoo-b59b7f4c09821fe30584c5c7ca9ff3abf64d4133.tar.bz2
gentoo-b59b7f4c09821fe30584c5c7ca9ff3abf64d4133.zip
app-admin/vault: remove old version
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-admin/vault')
-rw-r--r--app-admin/vault/vault-0.1.2.ebuild108
1 files changed, 0 insertions, 108 deletions
diff --git a/app-admin/vault/vault-0.1.2.ebuild b/app-admin/vault/vault-0.1.2.ebuild
deleted file mode 100644
index a910cd926236..000000000000
--- a/app-admin/vault/vault-0.1.2.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils fcaps golang-build systemd user
-
-GO_PN="github.com/hashicorp/${PN}"
-DESCRIPTION="A tool for managing secrets"
-HOMEPAGE="https://vaultproject.io/"
-SRC_URI="
- https://${GO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/mitchellh/gox/archive/v0.3.0.tar.gz -> gox-0.3.0.tar.gz
- https://github.com/mitchellh/iochan/archive/b584a329b193e206025682ae6c10cdbe03b0cd77.tar.gz -> iochan-b584a329b193e206025682ae6c10cdbe03b0cd77.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RESTRICT="test"
-
-DEPEND="dev-go/go-oauth2"
-RDEPEND=""
-
-STRIP_MASK="*.a"
-
-S="${WORKDIR}/src/${GO_PN}"
-
-FILECAPS=(
- -m 755 'cap_ipc_lock=+ei' usr/bin/${PN}
-)
-
-pkg_setup() {
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
-}
-
-src_unpack() {
- local x
-
- default
- mkdir -p src/${GO_PN%/*} || die
- mv ${P} src/${GO_PN} || die
-
- # Create a writable GOROOT in order to avoid sandbox violations.
- export GOROOT="${WORKDIR}/goroot"
- cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
- rm -rf "${GOROOT}/src/${GO_PN}" || die
-
- export GOPATH=${WORKDIR}:${WORKDIR}/src/github.com/hashicorp/vault/Godeps/_workspace:$(get_golibdir_gopath)
-
- while read -r -d '' x; do
- rm -rf "${GOROOT}/src/${x}" "${GOROOT}/pkg/${KERNEL}_${ARCH}/${x}"{,.a} || die
- done < <(find "${WORKDIR}/src/github.com/hashicorp/vault/Godeps/_workspace/src" -maxdepth 3 -mindepth 3 -type d -print0)
-
- mkdir -p "${GOROOT}/src/github.com/mitchellh" || die
- rm -rf "${GOROOT}/src/github.com/mitchellh/gox" || die
- mv gox-0.3.0 "${GOROOT}/src/github.com/mitchellh/gox" || die
- rm -rf "${GOROOT}/src/github.com/mitchellh/iochan" || die
- mv iochan-* "${GOROOT}/src/github.com/mitchellh/iochan" || die
-}
-
-src_prepare() {
- # Avoid the need to have a git checkout
- sed -e 's:^GIT.*::' \
- -e 's:-ldflags.*:\\:' \
- -i scripts/build.sh || die
-}
-
-src_compile() {
- go install -v -x github.com/mitchellh/gox || die
- PATH=${GOROOT}/bin:${PATH} emake dev
-}
-
-src_install() {
- local x
-
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
- newconfd "${FILESDIR}/${PN}.confd" "${PN}"
- systemd_dounit "${FILESDIR}/${PN}.service"
-
- keepdir /etc/${PN}.d
- insinto /etc/${PN}.d
- doins "${FILESDIR}/"*.json.example
-
- keepdir /var/log/${PN}
- fowners ${PN}:${PN} /var/log/${PN}
-
- dobin bin/${PN}
-
- egit_clean "${WORKDIR}"/{pkg,src}
-
- find "${WORKDIR}"/src/${GO_PN} -mindepth 1 -maxdepth 1 -type f -delete || die
-
- while read -r -d '' x; do
- x=${x#${WORKDIR}/src}
- [[ -d ${WORKDIR}/pkg/${KERNEL}_${ARCH}/${x} ||
- -f ${WORKDIR}/pkg/${KERNEL}_${ARCH}/${x}.a ]] && continue
- rm -rf "${WORKDIR}"/src/${x}
- done < <(find "${WORKDIR}"/src/${GO_PN} -mindepth 1 -maxdepth 1 -type d -print0)
- insopts -m0644 -p # preserve timestamps for bug 551486
- insinto /usr/lib/go/pkg/${KERNEL}_${ARCH}/${GO_PN%/*}
- doins -r "${WORKDIR}"/pkg/${KERNEL}_${ARCH}/${GO_PN}
- insinto /usr/lib/go/src/${GO_PN%/*}
- doins -r "${WORKDIR}"/src/${GO_PN}
-}