summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDevan Franchini <twitch153@gentoo.org>2017-06-22 19:26:56 -0400
committerDevan Franchini <twitch153@gentoo.org>2017-06-22 19:33:09 -0400
commit2ae9900b7310a643423546b3ee3bb847c55ffefe (patch)
tree02459d9dba61e632b43ddd64b080902110456e6e /app-admin/webapp-config
parentapp-text/mupdf: drop empty libmupdfthird.a file (bug 620874, thanks Cddr). (diff)
downloadgentoo-2ae9900b7310a643423546b3ee3bb847c55ffefe.tar.gz
gentoo-2ae9900b7310a643423546b3ee3bb847c55ffefe.tar.bz2
gentoo-2ae9900b7310a643423546b3ee3bb847c55ffefe.zip
app-admin/webapp-config: Deletes 1.54-r1 ebuild
Diffstat (limited to 'app-admin/webapp-config')
-rw-r--r--app-admin/webapp-config/webapp-config-1.54-r1.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/app-admin/webapp-config/webapp-config-1.54-r1.ebuild b/app-admin/webapp-config/webapp-config-1.54-r1.ebuild
deleted file mode 100644
index 2141c27bac3b..000000000000
--- a/app-admin/webapp-config/webapp-config-1.54-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
-
-inherit distutils-r1
-
-SRC_URI="https://dev.gentoo.org/~twitch153/${PN}/${P}.tar.bz2"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
-
-DESCRIPTION="Gentoo's installer for web-based applications"
-HOMEPAGE="https://sourceforge.net/projects/webapp-config/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+portage"
-
-DEPEND="app-text/xmlto
- sys-apps/gentoo-functions"
-RDEPEND="portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
-
-python_prepare() {
- epatch "${FILESDIR}/${P}-pvr-check.patch"
-}
-python_compile_all() {
- emake -C doc/
-}
-
-python_install() {
- # According to this discussion:
- # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
- # distutils does not provide for specifying two different script install
- # locations. Since we only install one script here the following should
- # be ok
- distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /etc/vhosts
- doins config/webapp-config
-
- keepdir /usr/share/webapps
- keepdir /var/db/webapps
-
- dodoc AUTHORS
- doman doc/*.[58]
- dohtml doc/*.[58].html
-}
-
-python_test() {
- PYTHONPATH="." "${PYTHON}" WebappConfig/tests/external.py \
- || die "Testing failed with ${EPYTHON}"
-}
-
-pkg_postinst() {
- elog "webapp-config now requires that all -I/-U/-C commands be followed"
- elog "by the package name and package version of the webapp"
- elog "eg.) 'webapp-config -d drupal -I drupal 8.0.0_beta10'"
- elog "See 'man 8 webapp-config' for more information"
-}