summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/whowatch/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/whowatch/files')
-rw-r--r--app-admin/whowatch/files/whowatch-1.8.4-select.patch17
-rw-r--r--app-admin/whowatch/files/whowatch-1.8.4-tinfo.patch19
2 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/whowatch/files/whowatch-1.8.4-select.patch b/app-admin/whowatch/files/whowatch-1.8.4-select.patch
new file mode 100644
index 000000000000..0907c70e6750
--- /dev/null
+++ b/app-admin/whowatch/files/whowatch-1.8.4-select.patch
@@ -0,0 +1,17 @@
+--- a/src/whowatch.c
++++ b/src/whowatch.c
+@@ -436,12 +436,12 @@
+ gettimeofday(&after, 0);
+ tv.tv_sec -= (after.tv_sec - before.tv_sec);
+ if(retval > 0) {
+- int key = read_key();
++ int key = getkey();
+ key_action(key);
+ }
+ if(tv.tv_sec <= 0) {
+ ticks++;
+- periodic();
++ main_periodic();
+ tv.tv_sec = TIMEOUT;
+ }
+ #endif
diff --git a/app-admin/whowatch/files/whowatch-1.8.4-tinfo.patch b/app-admin/whowatch/files/whowatch-1.8.4-tinfo.patch
new file mode 100644
index 000000000000..6ad7849ac037
--- /dev/null
+++ b/app-admin/whowatch/files/whowatch-1.8.4-tinfo.patch
@@ -0,0 +1,19 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -16,14 +16,8 @@
+ dnl Replace `main' with a function in -lkvm:
+ AC_CHECK_LIB(kvm, kvm_openfiles)
+ dnl Replace `main' with a function in -lncurses:
+-CURS=0
+-AC_CHECK_LIB(ncurses, scrollok, [CURS=1 ; LIBS="$LIBS -lncurses"])
+-if test "$CURS" != "1"; then
+- AC_CHECK_LIB(curses, scrollok, [CURS=1 ; LIBS="$LIBS -lcurses"])
+-fi
+-if test "$CURS" != "1"; then
+- AC_MSG_ERROR([Could not find proper curses library])
+-fi
++PKG_CHECK_MODULES(NCURSES, ncurses, [LIBS="$LIBS $NCURSES_LIBS"],
++ AC_MSG_ERROR([Could not find proper curses library]))
+
+ dnl Checks for header files.
+ AC_HEADER_DIRENT