summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-07-23 14:25:02 +0200
committerJeroen Roovers <jer@gentoo.org>2020-07-23 14:28:06 +0200
commitbacc65cfcb4038d6b2b780719a095555cc9d364b (patch)
tree16be76bf3274f870be498488c9d80b4e7906bc7c /app-admin/whowatch
parentdev-util/idea-community: Version bump (diff)
downloadgentoo-bacc65cfcb4038d6b2b780719a095555cc9d364b.tar.gz
gentoo-bacc65cfcb4038d6b2b780719a095555cc9d364b.tar.bz2
gentoo-bacc65cfcb4038d6b2b780719a095555cc9d364b.zip
app-admin/whowatch: Add live ebuild
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'app-admin/whowatch')
-rw-r--r--app-admin/whowatch/whowatch-99999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/whowatch/whowatch-99999.ebuild b/app-admin/whowatch/whowatch-99999.ebuild
new file mode 100644
index 000000000000..73c452f9523b
--- /dev/null
+++ b/app-admin/whowatch/whowatch-99999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools desktop git-r3
+
+DESCRIPTION="Displays information about users currently logged on in real time"
+HOMEPAGE="http://wizard.ae.krakow.pl/~mike/ https://github.com/mtsuszycki/whowatch/"
+EGIT_REPO_URI="https://github.com/mtsuszycki/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ sys-libs/ncurses:0=
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.4-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ dobin src/${PN}
+ doman ${PN}.1
+ dodoc AUTHORS ChangeLog.old NEWS PLUGINS.readme README.md TODO
+ domenu ${PN}.desktop
+}