summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-23 23:14:12 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-23 23:14:45 +0100
commit04c867d592a9e070c4cc9888d833212d21af323a (patch)
tree3b06c7ffd118832f125e4c828bf080e2856e09d6 /app-admin
parentdev-python/boto3: Use pytest-xdist to speed tests up (diff)
downloadgentoo-04c867d592a9e070c4cc9888d833212d21af323a.tar.gz
gentoo-04c867d592a9e070c4cc9888d833212d21af323a.tar.bz2
gentoo-04c867d592a9e070c4cc9888d833212d21af323a.zip
app-admin/awscli: Use pytest-xdist to speed tests up
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/awscli-1.22.61.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/app-admin/awscli/awscli-1.22.61.ebuild b/app-admin/awscli/awscli-1.22.61.ebuild
index 2fb60d145aa8..21a285d18863 100644
--- a/app-admin/awscli/awscli-1.22.61.ebuild
+++ b/app-admin/awscli/awscli-1.22.61.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
-inherit bash-completion-r1 distutils-r1
+inherit bash-completion-r1 distutils-r1 multiprocessing
DESCRIPTION="Universal Command Line Environment for AWS"
HOMEPAGE="https://pypi.org/project/awscli/"
@@ -28,6 +28,11 @@ RDEPEND="
>=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
distutils_enable_tests pytest
@@ -44,7 +49,8 @@ src_prepare() {
python_test() {
# integration tests require AWS credentials and Internet access
- epytest tests/{functional,unit}
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
}
python_install_all() {