summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2017-05-22 17:05:12 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2017-05-22 17:05:51 -0400
commit2d1b3ecdaa377617df46bd46785c86547d5ed75e (patch)
tree8aa0e103d8b35a240ff6aa27ee51827856934087 /app-admin
parentsys-apps/guix: bump up to 0.13.0 (diff)
downloadgentoo-2d1b3ecdaa377617df46bd46785c86547d5ed75e.tar.gz
gentoo-2d1b3ecdaa377617df46bd46785c86547d5ed75e.tar.bz2
gentoo-2d1b3ecdaa377617df46bd46785c86547d5ed75e.zip
app-admin/lastpass-cli: bump to 1.1.2 #617534
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/lastpass-cli/Manifest1
-rw-r--r--app-admin/lastpass-cli/lastpass-cli-1.1.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-admin/lastpass-cli/Manifest b/app-admin/lastpass-cli/Manifest
index 14217969e062..17a37c73eb87 100644
--- a/app-admin/lastpass-cli/Manifest
+++ b/app-admin/lastpass-cli/Manifest
@@ -1 +1,2 @@
DIST lastpass-cli-1.0.0.tar.gz 92311 SHA256 42096c0bd3972b0e9cc9cef32fbf141e47b04b9e2387fb3abe8b105e135fb41e SHA512 4709b3e4d6064c8c5cb593344e6417355d7df570240dce8eb77a19f3377ea38585280a9602cf8ab926c55c6afd84b297f261b0c8a40d355734d5cc542d46f610 WHIRLPOOL 394bfb597f5262dd1e47c7a3c48ef093b398f90c6dcacac6b172bb008891c76faf448ecf6be0ebfa277d18d335b166b7efadc063acc57ce88274004d1734bf21
+DIST lastpass-cli-1.1.2.tar.gz 102796 SHA256 bc737d8e6d713c8aecdfb7f34b29aa9a8ae9b1e9ba80b31059686b18591a8c39 SHA512 8115cb07cfca15ef402bdbd8ce943352e1534ddb781274e21cb0fafa4bcd9ab7abe4ddba57c4ebbce326f09cc9249f244607d16cac5597e61cf21c73417e7d9c WHIRLPOOL c7e6a4d5ac9b8c52f53e081b367289b390704fa4dfbf13a9ea0086e4ca0d49f9ef5a39f9ea854387ffb66fbd18f9b5263d17ae6573c4286fb7a36ebdce724d7f
diff --git a/app-admin/lastpass-cli/lastpass-cli-1.1.2.ebuild b/app-admin/lastpass-cli/lastpass-cli-1.1.2.ebuild
new file mode 100644
index 000000000000..d81e760b556d
--- /dev/null
+++ b/app-admin/lastpass-cli/lastpass-cli-1.1.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils bash-completion-r1
+
+DESCRIPTION="Interfaces with LastPass.com from the command line."
+HOMEPAGE="https://github.com/lastpass/lastpass-cli"
+SRC_URI="https://github.com/lastpass/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl X +pinentry"
+
+RDEPEND="
+ X? ( || ( x11-misc/xclip x11-misc/xsel ) )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ net-misc/curl
+ dev-libs/libxml2
+ pinentry? ( app-crypt/pinentry )
+"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBASH_COMPLETION_COMPLETIONSDIR="$(get_bashcompdir)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile all doc-man
+}
+
+src_install() {
+ cmake-utils_src_install install install-doc
+}