summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleksandr Trotsenko <oleksandr.trotsenko@gmail.com>2018-05-05 09:16:15 -0500
committerPatrice Clement <monsieurp@gentoo.org>2018-05-06 23:48:10 +0200
commit36b65c0cc3a13b57c1236c787bc290d2f229d43d (patch)
treebb1d469b160af0a6187ec3fccd1771b5287ff545 /app-admin
parentsci-libs/hdf: amd64 stable wrt bug #630868 (diff)
downloadgentoo-36b65c0cc3a13b57c1236c787bc290d2f229d43d.tar.gz
gentoo-36b65c0cc3a13b57c1236c787bc290d2f229d43d.tar.bz2
gentoo-36b65c0cc3a13b57c1236c787bc290d2f229d43d.zip
app-admin/apachetop: version bump.
Bumping the version to latest 0.18.4. Closes: https://bugs.gentoo.org/654970 Package-Manager: Portage-2.3.33, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/8270
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/apachetop/Manifest1
-rw-r--r--app-admin/apachetop/apachetop-0.18.4.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/apachetop/Manifest b/app-admin/apachetop/Manifest
index 49111859f763..75ab642f2210 100644
--- a/app-admin/apachetop/Manifest
+++ b/app-admin/apachetop/Manifest
@@ -1,2 +1,3 @@
DIST apachetop-0.12.6.tar.gz 126930 BLAKE2B 06d12cc72791920c959fa4ef8e18aa90f1f29a616389329685abf445f416cde9ce6edd2db5aaadaba51488033148e8109245200086a11422436ffe0aab1b4a40 SHA512 35081772f817c6a83a1fcf78790d2a288a9e4e48234c4b3163a09ad15f49a78d649b77f41aa002940fb9416c263cea159c5092a9b87285488eb450964c823c3a
DIST apachetop-0.17.4.tar.gz 128153 BLAKE2B 7601ce98618d041f6fc67e528775ce79b63a726b765ff298d1d74a1dd22a4451be6c36669c7ab9bf82fb8c120a6930d2bbf03823de02a216c558c358c53c07be SHA512 b5115048f79c694344fd341631fe7739567ba3ce6e18514d0be250cb6f42e04c54d35cc023dea5258725fcbfbb6debdaa51b91d64ae3120e70f5b78a7989a330
+DIST apachetop-0.18.4.tar.gz 128849 BLAKE2B 912f060984da326b2e005cc0e3eb99c28182bc6a0930e6781d5a0a990dbbe56b5dbfe871baea1c86a5ac2bc02faa1e583ca104d3c8bd00cc3617599601b2d8bd SHA512 e32f94ab6223578aa5b8c11083de762e8f916ba6d057d93f99208333632a8362b421c41fff76bf60a52f0b377a70d69c17ed02abfb95f86474ad3719016e59f7
diff --git a/app-admin/apachetop/apachetop-0.18.4.ebuild b/app-admin/apachetop/apachetop-0.18.4.ebuild
new file mode 100644
index 000000000000..2f5954eb82bf
--- /dev/null
+++ b/app-admin/apachetop/apachetop-0.18.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A realtime Apache log analyzer"
+HOMEPAGE="https://github.com/tessus/apachetop"
+SRC_URI="https://github.com/tessus/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="fam pcre"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ fam? ( virtual/fam )
+ pcre? ( dev-libs/libpcre )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-logfile="${EPREFIX}"/var/log/apache2/access_log \
+ --without-adns \
+ $(use_with fam) \
+ $(use_with pcre)
+}