summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-05-24 13:07:27 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-05-24 13:13:40 -0500
commit39df6ed2e244ad89cc01070ce3276d6399664299 (patch)
tree6f58030dcb748ae680fa5a08e89522ef74f33da1 /app-admin
parentx11-libs/libfm: Add missing dependency to glib-utils. (diff)
downloadgentoo-39df6ed2e244ad89cc01070ce3276d6399664299.tar.gz
gentoo-39df6ed2e244ad89cc01070ce3276d6399664299.tar.bz2
gentoo-39df6ed2e244ad89cc01070ce3276d6399664299.zip
app-admin/ansible: 2.6.17 and 2.7.11 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible/Manifest2
-rw-r--r--app-admin/ansible/ansible-2.6.17.ebuild66
-rw-r--r--app-admin/ansible/ansible-2.7.11.ebuild66
3 files changed, 134 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index caf8cc781b2f..2c689948983c 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -1,5 +1,7 @@
DIST ansible-2.6.14.tar.gz 10732165 BLAKE2B c753860a521c37357c7a5042391957680865416c036fcaf3920a65e291dc3ed3a52e94ad5b99acdb0d2c919e3be68b8462e462a935497dfe83b406adf4e63dad SHA512 ee532c0d61ab03a0937e89bfa7565f27f1905987784f31895e8ac6e4a8ecf76ca9f30201d278a68a995b8fc27151712dba2e79c13269a472d923355e36072e4e
DIST ansible-2.6.16.tar.gz 10738431 BLAKE2B b801eb524f631950c385f7a949bdeae288e95d1590ea96f98e955f6ebc4ccfc5970e3926727850e7ef13fbcd7118ad6388e516a8fe62b53f1bf8b4d5b484dbab SHA512 ff67803cf6afd512ab779b7c862d4427591c90bb0ed9391e32fc8ea30c24c70cc31c910c9af51b4dd423885f858f65c1c8d6274565c90296ecd7a00df3374977
+DIST ansible-2.6.17.tar.gz 10742849 BLAKE2B 04667612ab7d149d7a322ce674c2256164c0d958d3e5b34cafeba0b90d4f0f07ee95a31bf0c205c13c90ee4d63c3045ce2fc51de8996a7dcb877d39e2da680f5 SHA512 ba46192549be3e853232d865116c176aebd8ed2b63fcbb45cb633d3809fc534004849a70a2abad80f9fe99deeb55af3883ce1bfe0db4a9afd2f6b8045936e860
DIST ansible-2.7.10.tar.gz 11844278 BLAKE2B c847b642ebe4cbc2194538a0b194cd5c0bb82e0ba2a6da2e272670c75596b9793e028d067ddb37000c07f2c2427b5b99248b16c544daed4976c0210b601d3c97 SHA512 4d58ef080c8ee02ef36eb3116ec89e4542b5b4042262953b2001081601fe1066237191cce5e647f354efa9e1933cf5010519d049e678a90e8ca08620cd1788a5
+DIST ansible-2.7.11.tar.gz 11855636 BLAKE2B 3de8fa1287655f778b1d9036bf78a91387cf238209eb2bfd17ee79f7d77a2e03ae734901bdc04226d635b3d8543d122aaa251107befab8cc4a4fc63cfcd8deec SHA512 06f805a701f8284ac1a65251b9358cf6f27d420aabb1e29298f9e4d8aa73251bd4a8e8a3981f744b97b2f750fd3b594a9b505e5baa3ff2cb3aa7a37603ba48fa
DIST ansible-2.7.9.tar.gz 11830476 BLAKE2B 7688ce9f74b0ab1fafd0e31dce90d995a9d8ca90bbe436f2d4ee9d005069b6e1b2c4dd679c2430a6873233da54ae06d3ebf08736681ec2e59e5b3ddafa6bb1e2 SHA512 4d39c7d4eb97264ce8f92812fb986b24af0c663efa6d8cd1d9a4cb25731d55e7518e503c04764e62d0458916b601baaa7acc623f9f83ce8b93e7f22900e29a53
DIST ansible-2.8.0.tar.gz 14285827 BLAKE2B 090c314e0c707e24ce4c21722bfbb34d18d95e6e8cd63b06af78e41fedb3183adbdf6718da1bb8a2c7037f9ea9ffffb96add17a44cb199d0c000c1d6f88cd53e SHA512 fab8a0ac00e947e47ab606bee0a15e8c031f900b5e6fc68540429db0035ffdf3144e18e1d2265ac07bbea0a78873b85c43e636ee51ecfe14f3d612d2c54eb29c
diff --git a/app-admin/ansible/ansible-2.6.17.ebuild b/app-admin/ansible/ansible-2.6.17.ebuild
new file mode 100644
index 000000000000..4bec3453ac7f
--- /dev/null
+++ b/app-admin/ansible/ansible-2.6.17.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+# not included in release tarball
+RESTRICT="test"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ doman docs/man/man1/*.1
+ dodoc -r examples
+}
diff --git a/app-admin/ansible/ansible-2.7.11.ebuild b/app-admin/ansible/ansible-2.7.11.ebuild
new file mode 100644
index 000000000000..63e11740ae9c
--- /dev/null
+++ b/app-admin/ansible/ansible-2.7.11.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+# not included in release tarball
+RESTRICT="test"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ doman docs/man/man1/*.1
+ dodoc -r examples
+}