summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-21 22:01:17 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-21 22:36:16 +0100
commit4a63fcf87c3d2ef3e039b8f6531e16f2e6a0975e (patch)
treea43faad62933a307714863e485b990128e4ce4f1 /app-admin
parentdev-python/boto3: Bump to 1.21.4 (diff)
downloadgentoo-4a63fcf87c3d2ef3e039b8f6531e16f2e6a0975e.tar.gz
gentoo-4a63fcf87c3d2ef3e039b8f6531e16f2e6a0975e.tar.bz2
gentoo-4a63fcf87c3d2ef3e039b8f6531e16f2e6a0975e.zip
app-admin/awscli: Bump to 1.22.59
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.22.59.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index e5d9fec02119..85cb89804b51 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -7,3 +7,4 @@ DIST awscli-1.22.55.tar.gz 2164540 BLAKE2B 7e69d2810ba3a829522e4ada836f70d229ac6
DIST awscli-1.22.56.tar.gz 2164531 BLAKE2B 86ed7632aded1a5c3b18d2eabfbf5fd9954ef2d8f61ebf5c23e596452381a3915909d6fc93c92eaa5d58f02a27df994476fbc847b40984c141946e6f08933dd8 SHA512 fb4ad95f2990397fb1d83559e71dbebf1b4f2f52b46912da02bded1d486a61141c94dabc0f59ba2ffd724ef7e379f66113a71f2ea466e7a28cf6ac9582579004
DIST awscli-1.22.57.tar.gz 2164852 BLAKE2B 4387cd8a93972f23149c722aa03ce26f9d9fe8daa908d3d9db6e6e845265089a663d8b20f6cb7bd858f69ca29cbbda94813f58349921659534250177eb21dea6 SHA512 ad7912aa9bd2318b043796ffce4df42915e4af60ce85f76236ff9e9c1b06ef87a7acc45e560abcfc48c06ab9f14a9d3ebad12b9d02a02f66c9bbaccbbcc66100
DIST awscli-1.22.58.tar.gz 2165016 BLAKE2B d7eec5a51a64d3a78555abfd4a3dd70a02b4e2c4399b57a023bf81603946cbbce3c0a5e49b02d90adfc74ea9d060f72d0350a9673abe855164aede6e35530085 SHA512 62e9eff1c8d0ad035566fb97bf26d52554cf314c35bf2277062aadcaa7d96a8c1cb949c85f61a79ace17821f5355d93aeb9f5692b8ca417e852fa4e3aa1325c9
+DIST awscli-1.22.59.tar.gz 2165629 BLAKE2B f4223e9095a76121a94345219057b94b830c80c233ebec8864110945d71317e94fe2f08f02e059816f1bdd9e1e2f4800e1f9770559bec4df51d5d39286e11bd0 SHA512 0efa161c976e6dd6168a7d8808298a196c0c6e3d4b54c9130efcf88179d6e6f78ae0a231a6c31e1615c84165ba33fffebefccd322442289537c9502102b5ee11
diff --git a/app-admin/awscli/awscli-1.22.59.ebuild b/app-admin/awscli/awscli-1.22.59.ebuild
new file mode 100644
index 000000000000..2fb60d145aa8
--- /dev/null
+++ b/app-admin/awscli/awscli-1.22.59.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# awscli 1.22.55 → botocore 1.24.0
+# so botocore is x.(y+2).(z-55)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(( $(ver_cut 3-) - 55))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}