summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2019-09-23 15:41:42 +0200
committerAlexys Jacob <ultrabug@gentoo.org>2019-09-23 15:43:43 +0200
commit4b25a8195fa220854003ea5b3fda2d2bd8d46255 (patch)
tree0ed53f410736543a47cced97c4a09cbfba705cbc /app-admin
parentdev-python/cheetah3: blocker on cheetah for file collision (diff)
downloadgentoo-4b25a8195fa220854003ea5b3fda2d2bd8d46255.tar.gz
gentoo-4b25a8195fa220854003ea5b3fda2d2bd8d46255.tar.bz2
gentoo-4b25a8195fa220854003ea5b3fda2d2bd8d46255.zip
app-admin/mongo-tools: version bump
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/mongo-tools/Manifest1
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.6.14.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-admin/mongo-tools/Manifest b/app-admin/mongo-tools/Manifest
index f5f6e6c8a0ec..8f5e9f7f8de1 100644
--- a/app-admin/mongo-tools/Manifest
+++ b/app-admin/mongo-tools/Manifest
@@ -1,4 +1,5 @@
DIST mongo-tools-3.6.13.tar.gz 4990848 BLAKE2B 022ddf214869c3a3e545aa9572f77f0adc21c0dbd6ea6ad9e083633c2e972b7ef77c0bda4354dbde9fd0e23c6dd02a7de8873d4b2c2a3e4423ea6f8e1c23ed52 SHA512 fac21c4841bfecba11a7765bb6c36d1fa19d4dd94f6f4168fa767fc11dc8b3caf04a5029becd09eba01dd694274e9cc22da8566ce878769e5c3c97016c162432
+DIST mongo-tools-3.6.14.tar.gz 4990861 BLAKE2B 13394a7222e73c0912e7d9d04205b25e5d73d6c72b53521b0749e0998dc52bbe4c7733d460b189aff2401790f537d9aa369b969ed273ea0858520ecd75782b66 SHA512 3e7caaa1d568023d478c77d5e88127796b25d27c71e30af692983f4fd2160887662253ffc67e6e87aa3a7e1fd4ae231de9401b1628412a4561b9595b71df8834
DIST mongo-tools-3.6.8.tar.gz 4723878 BLAKE2B a1693024d60f69d25c268eaaa30a478b1e4c0042c5fb7a3fd6252ed00aef2fee3fba94516fe825165a1a57887ed38e4fbce488c48ddd4f45349f0b7a1b244020 SHA512 359e8ce2d847d005d48ff12bc2e8af73213d81cd1521d2b5b5ac94792468218248bebbe808e1bd8fd49234eab8480608f294c1b63f317aed58f456b84ef17dcf
DIST mongo-tools-4.0.10.tar.gz 11134721 BLAKE2B f25e834622db8a2cea1658d9396b747666dee6a0e6471f5fcf351431f716735227b19f854c228ebb9ace8a7c27b8cdf83f8a5009107191aa6dd27c1a4c037505 SHA512 12764b2e2016ae3ab3f0ed1f5b9be9ce10e466c53b408ad2c01b26bdf39ca41a358acd07aea5847db2b40e3e89293f77efcd2b310e4e2bf3071873abf1b20f49
DIST mongo-tools-4.0.12.tar.gz 11134652 BLAKE2B d3c9703046dc577b85cefe1185678e0029411ddd44d0648f9b09fc3ab41e3661891d18afd83bf1a148dc4c9208895f444c115948e515e09dfa3062e89d98fc24 SHA512 068d8c456386caddcce23fa8917ffecdc9b5c39fb6794c5cd1d9099be1f127ecf680b006055581dc3d90507072a87788b46be7410f0dbede42da64c664b77ced
diff --git a/app-admin/mongo-tools/mongo-tools-3.6.14.ebuild b/app-admin/mongo-tools/mongo-tools-3.6.14.ebuild
new file mode 100644
index 000000000000..092d770686fb
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-3.6.14.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="https://www.mongodb.com"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="sasl ssl"
+
+DEPEND="dev-lang/go:=
+ net-libs/libpcap
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl:0= )"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+EGO_PN="github.com/mongodb/mongo-tools"
+S="${WORKDIR}/src/${EGO_PN}"
+
+src_unpack() {
+ mkdir -p "${S%/*}" || die
+ default
+ mv ${MY_P} "${S}" || die
+}
+
+src_prepare() {
+ default
+
+ # allow building with go 1.12 #678924
+ sed -i 's/_Ctype_struct_/C.struct_/' vendor/github.com/google/gopacket/pcap/pcap.go || die
+}
+
+src_compile() {
+ local myconf=()
+
+ if use sasl; then
+ myconf+=(sasl)
+ fi
+
+ if use ssl; then
+ myconf+=(ssl)
+ fi
+
+ # build pie to avoid text relocations wrt #582854
+ local buildmode="pie"
+
+ # skip on ppc64 wrt #610984
+ if use ppc64; then
+ buildmode="default"
+ fi
+
+ mkdir -p bin || die
+ for i in bsondump mongostat mongofiles mongoexport mongoimport mongorestore mongodump mongotop mongoreplay; do
+ echo "Building $i"
+ GOROOT="$(go env GOROOT)" GOPATH="${WORKDIR}" go build -buildmode="${buildmode}" -o "bin/$i" \
+ -ldflags "-X ${EGO_PN}/common/options.VersionStr=${PV}" --tags "${myconf[*]}" "$i/main/$i.go" || die
+ done
+}
+
+src_install() {
+ dobin bin/*
+}