summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-12-07 10:03:53 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2016-12-07 10:03:53 -0600
commit51776187a5dacecf326489f7becc129f7ab7dad9 (patch)
treeba00188efa9f32578c2f3389da2e83b56f6499a6 /app-admin
parentapp-office/homebank: remove 5.0.6, 5.0.7 and 5.0.8 (diff)
downloadgentoo-51776187a5dacecf326489f7becc129f7ab7dad9.tar.gz
gentoo-51776187a5dacecf326489f7becc129f7ab7dad9.tar.bz2
gentoo-51776187a5dacecf326489f7becc129f7ab7dad9.zip
app-admin/puppet-agent: bup
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-1.8.2.ebuild103
2 files changed, 105 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index 90cb8d36de51..05afb1ab393d 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -2,3 +2,5 @@ DIST puppet-agent_1.7.1-1xenial_amd64.deb 13901688 SHA256 f9f0cedcb29f054064bc2b
DIST puppet-agent_1.7.1-1xenial_i386.deb 15252694 SHA256 0e2c94907bcd0174e5518a72eb91b4e66639ffa2829292044782658b7762fd19 SHA512 b1f85586848cff2b6790c93a320a7c8ee226d78dca14ddcf947e9d01c1b105b379cb0e044280640e95873e7abd31c3873d6e90117c249c314ae948bca36bad17 WHIRLPOOL b2460598fd12fdd565e6cc131a8e14d4eb411b233ce5125e436d09432fa5f9fca9d9065c515b53d0a26811a18d120cc0bcae0e9c848ed19820d89903d27340c3
DIST puppet-agent_1.8.1-1xenial_amd64.deb 15184048 SHA256 380bada6281c8785aa91ae60434afd3f36f470c723d09746274f8d91a872e23e SHA512 d0457a7b7024d1f00cb11b6287f17d6dea8411bf183e5610e7a0657400914aa9a3c02609b159e00ff8dde1ac433e33f9499a257e4edd7a1bc4f9e74a2f7765ee WHIRLPOOL a7279a33efc8798ece02be5135b7a777d1e339dccbc5fc1cbd9d0ee0fbb05e490d8a6bf17c3454e836729a8deb80250328375a93e22c925bf4eeeba711f7c2d8
DIST puppet-agent_1.8.1-1xenial_i386.deb 16608626 SHA256 8908e987ba451d34e54210e0cfa6f1269a1e678f695c4f73c284216d5fa4522a SHA512 a6124489752172e9e5e5899ef032a5d2e7ed3de2096f9055f63d77358035ad2672ebddb075f73aed5d13660d2b40add8bc0962c56b9ec1942463dbe3847297aa WHIRLPOOL 034c9c026d0607d02e98267ec422cadd14dfa934866c962904ceecb1f1de4c22e1adb76e763a6b5c46c5c2dcd29e9f8bb89a9450517fa33706b1f48412acc5ba
+DIST puppet-agent_1.8.2-1xenial_amd64.deb 15179348 SHA256 5195af288ca014bcf65705c3fb83a1da8caf02eb1f431396380951480fb7e2dc SHA512 6093012994faaa3e7248c3e705e2dcb9269c85cfd4405c7ac66ab0adf3a547bc37ad3f5d44530514ed30a4edb01c01522eae1bced8d7ebade9ceb737ee600449 WHIRLPOOL 9905c00b16b12b75b331faf60c5ba3ad948a04db1ad4ef9b11aa413442fd464b836cc295cb4e0d85c34ebb3f97f470141cf207491fbeedb7964409ab75420f44
+DIST puppet-agent_1.8.2-1xenial_i386.deb 16609778 SHA256 48d4588ae8c87a3a3e41c5c4e6159cba7bf6484578ce0761b4abd76854f7bdad SHA512 b96e239906e75773a22c37a28c3c794b7293cab1a970ba5067064b120e12e0a6f0b620f06dfb3cc5b83e9140467fa552aa05ea46a33f3fb8b489ac7790cb7734 WHIRLPOOL 6daf05a7ae5e50ecb922ffa260101cc62e64267fd40ca6dd8d684ab1b3760eb45a4f797f9644b7fb351f70a86e88d5c88cd1cc5dd4d68341912846466ba72257
diff --git a/app-admin/puppet-agent/puppet-agent-1.8.2.ebuild b/app-admin/puppet-agent/puppet-agent-1.8.2.ebuild
new file mode 100644
index 000000000000..5d616911a0ac
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-1.8.2.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd unpacker user
+
+DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/xenial/PC1/${PN:0:1}/${PN}/${PN}_${PV}-1xenial"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+ !app-admin/mcollective
+ !app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what"
+
+DEPEND="
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-3.1.0 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="
+ /opt/puppetlabs/puppet
+ /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/mathn/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/io/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/dl/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/racc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/enc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/json/ext/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/rbconfig/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/digest/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/engines/*
+ /opt/puppetlabs/puppet/lib/virt-what/*
+ /opt/puppetlabs/puppet/lib/*
+ /opt/puppetlabs/puppet/bin/*"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/run/puppet puppet
+}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/mcollective
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/mcollective
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ newinitd "${FILESDIR}/mcollective.initd" mcollective
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/mcollective.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym /opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym /opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym /opt/puppetlabs/bin/mco /usr/bin/mco
+ dosym /opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym /opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
+ dosym /opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym /opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+ dosym /opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+ dosym /opt/puppetlabs/puppet/bin/extlookup2hiera /usr/bin/extlookup2hiera
+}