summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-06-28 22:02:09 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-06-28 22:02:40 -0500
commit52042b64b642cb02a42516758265e9101254f5a5 (patch)
tree9d1e5fbb92cc828c1b15ae4f336ee0be828e9c06 /app-admin
parentdev-ruby/facter: bumping ruby versions supported (diff)
downloadgentoo-52042b64b642cb02a42516758265e9101254f5a5.tar.gz
gentoo-52042b64b642cb02a42516758265e9101254f5a5.tar.bz2
gentoo-52042b64b642cb02a42516758265e9101254f5a5.zip
app-admin/puppet: 5.0.0 initial add
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet/Manifest1
-rw-r--r--app-admin/puppet/puppet-5.0.0.ebuild184
2 files changed, 185 insertions, 0 deletions
diff --git a/app-admin/puppet/Manifest b/app-admin/puppet/Manifest
index 92661991a7be..214ae54654f8 100644
--- a/app-admin/puppet/Manifest
+++ b/app-admin/puppet/Manifest
@@ -2,3 +2,4 @@ DIST puppet-3.8.7.tar.gz 2650247 SHA256 50460a3dd8d25118e25eb01178d09743dabc01cd
DIST puppet-4.10.1.tar.gz 2954351 SHA256 271738d2b5aaec8faafd543076ac0d9012fcd6051bccd2f70a66cd479362c605 SHA512 d232f062b93485f7eea8abb9c5420462e313e6050e7335159f051f7c7af86338c006ae4edc09e0e1370784ee7b076911ca563a4cfc6a1f2afc7179bed08d2032 WHIRLPOOL 1a5b8c3fc87fdb4e23196cc13ad46c963cdb6314cfc0e4d3a6d44adad4545289cf41886c6150ee14fcd0d30d9b29f32987c6e31a7c39077a2c53aac7147c69dd
DIST puppet-4.8.1.tar.gz 2873371 SHA256 8b3ee6b60639e2a2839ad7403fab8f8ecc390a93e6e47b03f1b053aa262bcf17 SHA512 9ecde04c68874652b501e779764bb3227d226564e80f06c2c15bd982620529ec55f8e11911bcf68db994ee98287746761752538aa5aeee474ddf37f21976e2d1 WHIRLPOOL d3a4b0b4b15dceb75cb3f161b73843af53f5d21121ba1fb06fdae422ec458f62f5fa47d0f5c7bfb96e3e9b04eb62c4c1e1a97f7131101e4f6f4ff952127c0685
DIST puppet-4.9.1.tar.gz 2912770 SHA256 db02cffb8339b349bd1ab2b15899511d3f5d449f0f591038256f0fb862f4c7db SHA512 db2bd324e4f58c583debe417ca233c613c296aa8824520c5373c8da45056ae9d09e54ceecba5c6b7d0250ea7228d6e1b83e5b690b1203de43dca8942c8f24ce2 WHIRLPOOL fd5554d5de319f8534fbada7ae6f4100d6de5a98f6646985e21c250a52a3d415ac31fc46c15c987bd7bcbc688bc8bb4d7dc9d37ebd93ecd183b3bd01d3426687
+DIST puppet-5.0.0.tar.gz 2706319 SHA256 09ae5b56ff799ccfd78e3a1999aa27d6f2bf69a7a5ed19bd758cf88c17a004ab SHA512 4423001340623d00a72de16e7b585ce3874019b020b91abd4edb9b9a524bd0d709107bee4dfcdf20b2eaf99e67b3401e2883ea297659ad1debfea8fb33a665bd WHIRLPOOL 66bbb279fb9d646ada78ce28af3d2377abf63ce059b9e61ee15fc0b3b48796ea0f708f5f2c380e5dd986d4469f6a8b73606c61dfc3280aca5913d9c7fffa4f2f
diff --git a/app-admin/puppet/puppet-5.0.0.ebuild b/app-admin/puppet/puppet-5.0.0.ebuild
new file mode 100644
index 000000000000..f7ab070e41ec
--- /dev/null
+++ b/app-admin/puppet/puppet-5.0.0.ebuild
@@ -0,0 +1,184 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+USE_RUBY="ruby21 ruby22 ruby23"
+# need to get deps up to date for this
+#USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit elisp-common xemacs-elisp-common eutils user ruby-fakegem versionator
+
+DESCRIPTION="A system automation and configuration management software."
+HOMEPAGE="http://puppetlabs.com/"
+SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="augeas diff doc emacs experimental ldap rrdtool selinux shadow sqlite vim-syntax xemacs"
+RESTRICT="test"
+
+ruby_add_rdepend "
+ dev-ruby/hiera
+ >=dev-ruby/rgen-0.6.5
+ dev-ruby/json:=
+ >=dev-ruby/facter-3.0.0
+ augeas? ( dev-ruby/ruby-augeas )
+ diff? ( dev-ruby/diff-lcs )
+ doc? ( dev-ruby/rdoc )
+ ldap? ( dev-ruby/ruby-ldap )
+ shadow? ( dev-ruby/ruby-shadow )
+ sqlite? ( dev-ruby/sqlite3 )
+ virtual/ruby-ssl
+ dev-ruby/hocon"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha
+ dev-ruby/rack
+ dev-ruby/rspec-its
+ )"
+# this should go in the above lists, but isn't because of test deps not being keyworded
+# dev-ruby/rspec-collection_matchers
+
+DEPEND+=" ${DEPEND}
+ emacs? ( virtual/emacs )
+ xemacs? ( app-editors/xemacs )"
+RDEPEND+=" ${RDEPEND}
+ rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
+ >=app-portage/eix-0.18.0"
+
+SITEFILE="50${PN}-mode-gentoo.el"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/lib/puppet puppet
+}
+
+all_ruby_prepare() {
+ # Avoid spec that require unpackaged json-schema.
+ rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
+
+ # can't be run within portage.
+ epatch "${FILESDIR}/puppet-fix-tests-4.7.0.patch"
+
+ # fix systemd path
+ epatch "${FILESDIR}/puppet-systemd.patch"
+
+ if use experimental; then
+ epatch "${FILESDIR}/43e2c935252b995134ce353e5e6312cf77aea480.patch"
+ fi
+
+ # Avoid specs that can only run in the puppet.git repository. This
+ # should be narrowed down to the specific specs.
+ rm spec/integration/parser/compiler_spec.rb || die
+
+ # Avoid failing spec that need further investigation.
+ rm spec/unit/module_tool/metadata_spec.rb || die
+}
+
+all_ruby_compile() {
+ if use emacs ; then
+ elisp-compile ext/emacs/puppet-mode.el
+ fi
+
+ if use xemacs ; then
+ # Create a separate version for xemacs to be able to install
+ # emacs and xemacs in parallel.
+ mkdir ext/xemacs
+ cp ext/emacs/* ext/xemacs/
+ xemacs-elisp-compile ext/xemacs/puppet-mode.el
+ fi
+}
+
+each_ruby_install() {
+ each_fakegem_install
+# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # systemd stuffs
+ insinto /usr/lib/systemd/system
+ doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
+
+ # tmpfiles stuff
+ insinto /usr/lib/tmpfiles.d
+ newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
+
+ # openrc init stuff
+ newinitd "${FILESDIR}"/puppet.init-4.x puppet
+ newinitd "${FILESDIR}"/puppetmaster.init-4.x puppetmaster
+ newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
+
+ keepdir /etc/puppetlabs/puppet/ssl
+
+ keepdir /var/lib/puppet/facts
+ keepdir /var/lib/puppet/files
+ fowners -R puppet:puppet /var/lib/puppet
+
+ fperms 0750 /var/lib/puppet
+
+ fperms 0750 /etc/puppetlabs
+ fperms 0750 /etc/puppetlabs/puppet
+ fperms 0750 /etc/puppetlabs/puppet/ssl
+ fowners -R :puppet /etc/puppetlabs
+ fowners -R :puppet /var/lib/puppet
+
+ if use emacs ; then
+ elisp-install ${PN} ext/emacs/puppet-mode.el*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ if use xemacs ; then
+ xemacs-elisp-install ${PN} ext/xemacs/puppet-mode.el*
+ xemacs-elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ if use ldap ; then
+ insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
+ fi
+
+ # ext and examples files
+ for f in $(find ext examples -type f) ; do
+ docinto "$(dirname ${f})"; dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ elog
+ elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
+ elog "cause puppet to hang while installing packages."
+ elog
+ elog "Portage Puppet module with Gentoo-specific resources:"
+ elog "http://forge.puppetlabs.com/gentoo/portage"
+ elog
+
+ if [ "$(get_major_version $REPLACING_VERSIONS)" = "3" ]; then
+ elog
+ elog "If you're upgrading from 3.x then please move everything in /etc/puppet to"
+ elog "/etc/puppetlabs/puppet"
+ elog "Also, puppet now uses config directories for modules and manifests."
+ elog "See https://docs.puppetlabs.com/puppet/4.0/reference/upgrade_agent.html"
+ elog "and https://docs.puppetlabs.com/puppet/4.0/reference/upgrade_server.html"
+ elog "for more information."
+ elog
+ fi
+
+ use emacs && elisp-site-regen
+ use xemacs && xemacs-elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+ use xemacs && xemacs-elisp-site-regen
+}