summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-09-17 16:32:06 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-09-17 16:37:29 -0500
commit578bd26af5cd42439b0442d22dcf0bf825813b1a (patch)
treef4de9d7995ccfd98aeecac9249b43de38ba4fcbc /app-admin
parentapp-admin/puppet: 7.11.0 bump (diff)
downloadgentoo-578bd26af5cd42439b0442d22dcf0bf825813b1a.tar.gz
gentoo-578bd26af5cd42439b0442d22dcf0bf825813b1a.tar.bz2
gentoo-578bd26af5cd42439b0442d22dcf0bf825813b1a.zip
app-admin/puppet-agent: 7.11.0 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet-agent/Manifest1
-rw-r--r--app-admin/puppet-agent/puppet-agent-7.11.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index 8d2c8d6c1ad0..17e880c5d05a 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -1,4 +1,5 @@
DIST puppet-agent_6.19.1-1focal_amd64.deb 22221600 BLAKE2B 22b03ef1f86b34955e8bad7c63a2022d2832dadd554316baf75419d6543e8a569902fb92a81a3dcc817401f06aa7dd47143a6cbd383f0e531c465cd3203dc4ed SHA512 4819a3509066516b0be76bc0f2afe94611405f7ac52fe50890d57c86a8a9c6c70787d46cb4b77085666f3e74bcb83a11acf1fef5d1e6ed3151ea06cbb8df3170
DIST puppet-agent_7.10.0-1focal_amd64.deb 20964600 BLAKE2B 160a5abf3dccb57b325283f9ec6f908be73aaa065787bc6cefe2db0fbfd67145a42cab1a763e2e14c64b7902c50814b09a4b4763aaa504536f289b485cd41a6b SHA512 88c2907e47ad3009c9ce9089d3fb91da68c6c80d9d50fbf714332f2f637ad69adc122a88042cac020ae9c637b07e6569ffab7998ca08aa57a67254748cce5d30
+DIST puppet-agent_7.11.0-1focal_amd64.deb 20968988 BLAKE2B 41c1464290fc38b9bb2a79384c6c427ec8cd1332b3ccba155cb26d43a87b36931415d3a54a10ae8f6a1322f02eeaef27147d4af7304f541ce38e668b072cc03c SHA512 38024f80af5ef69a1db22f9ed90b7b00af5183988b2029fa63a8b2fa1de1c189ba164d8cd450156c4d822a3e6404e5933ca09efdd4eeee7188c99791991a9921
DIST puppet-agent_7.8.0-1focal_amd64.deb 20931500 BLAKE2B 3c521631fb96440e51ad82c3665f07a5ee9cba1d978fccbe9388684ad0c211138f022017ff49b92818cfc8f50ebed0a996c9321918413e4a1c7ca0f5a2f68f8a SHA512 f0cd9951b54bc9aacce987ea10e9257db9432620f50657ca220ea8b7b4aad1c5ddebd6f5e89c5bdee837b0f928bbebe375afdb72652eb33ee22e3778498aafa1
DIST puppet-agent_7.9.0-1focal_amd64.deb 20934808 BLAKE2B 4b5c529e1a5cb5877a753b09a477fc08e7ca7a93c3b1dae5062864d2887adea584075f4ca6b963e01cb5121ce06008182cfc39124b9e22559899beb03855240f SHA512 b6c94b65febd6b76f1ab7af5f4f5238fb314b2abb226dd5828f09ca46fdf4cd22641f765ea338b3aeb7ccf6e0fe37d5682586fbef7dc27b51a654ded6f774495
diff --git a/app-admin/puppet-agent/puppet-agent-7.11.0.ebuild b/app-admin/puppet-agent/puppet-agent-7.11.0.ebuild
new file mode 100644
index 000000000000..c24ff0f353a2
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-7.11.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit systemd unpacker tmpfiles
+
+DESCRIPTION="general puppet client utils along with hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_URI="http://apt.puppetlabs.com/pool/focal/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1focal_amd64.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ app-emulation/virt-what
+ acct-user/puppet
+ acct-group/puppet"
+
+DEPEND="
+ ${CDEPEND}
+ app-admin/augeas"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/libselinux
+ sys-libs/glibc
+ sys-libs/readline:0/8
+ sys-libs/libxcrypt[compat]
+ sys-libs/ncurses:0[tinfo]
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ keepdir var/log/puppetlabs/puppet/
+ chmod 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd2" puppet
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ newtmpfiles usr/lib/tmpfiles.d/puppet-agent.conf puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym ../../../../usr/lib/libcrypt.so.1 /opt/puppetlabs/puppet/lib/libcrypt.so.1
+}
+
+pkg_postinst() {
+ tmpfiles_process puppet-agent.conf
+}