summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-10-12 19:01:22 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-10-12 19:03:54 -0500
commit6046facdd6b01453f67c389a15adf2d5d80a4346 (patch)
treea1a0983879201331e5c82ce8d6d1a1a4a6f9978c /app-admin
parentwww-apache/mod_jk: Keyword 1.2.48 arm64, #800512 (diff)
downloadgentoo-6046facdd6b01453f67c389a15adf2d5d80a4346.tar.gz
gentoo-6046facdd6b01453f67c389a15adf2d5d80a4346.tar.bz2
gentoo-6046facdd6b01453f67c389a15adf2d5d80a4346.zip
app-admin/ansible: 4.6.0 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-4.6.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index b99a9a5ba390..462a1bbb1a90 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -1,2 +1,3 @@
DIST ansible-4.3.0.tar.gz 35135987 BLAKE2B 6f4bf55f07275b7264a7fba693816bf925d574d4da3d4d13af9b85c44d4b5adf9e823b9bd936408a0e424273f8f2aa529e960105842444d26eb3f45973109ec5 SHA512 035a236d0762e425c4ce4ffd709386075aee438bb8085a25920543bb2378feb07fb8f0a50ce9fb6b0d1f5dde1f27a408b828c286bfc1173d38da5f8c7b572c3a
DIST ansible-4.5.0.tar.gz 35530106 BLAKE2B 3176f374df6b9e7fdb8554187f8132a25b474627d66729c776e5935ee0eb84c296e951a511afec6787bb1cebda8d72670f9305e1904cff221229a459a671ddf7 SHA512 fd8461d22d6d3fd325a12480d78009cf65580c790c56164a50c5d74061034a1f387772f687bc730d23192a9a72221f87e11a44e984d05308311b9d6d2441a976
+DIST ansible-4.6.0.tar.gz 35644507 BLAKE2B 94f544caa81ba7d20493f469483612f2ebf9eb1c4be18006b5ca6afdb3bd45428226340a0658b8f1ebecf8bd06396763ba888bb1cbd48aa6b71aaa6a56542d38 SHA512 5b7fad69628dded0b42a25e3f2fbbcc30ef876dc3f97dc1dff2c7db6443d1506fe5db62bc4d8a00ebfb7dc78ecc205a56bea3bf760f85260c835b2286f63b702
diff --git a/app-admin/ansible/ansible-4.6.0.ebuild b/app-admin/ansible/ansible-4.6.0.ebuild
new file mode 100644
index 000000000000..7b9608af55af
--- /dev/null
+++ b/app-admin/ansible/ansible-4.6.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+RESTRICT="test"
+
+RDEPEND=">=app-admin/ansible-base-2.11.1
+ <app-admin/ansible-base-2.12"
+
+python_compile() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+python_install() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_install
+}