summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-01-21 11:01:17 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-01-21 11:18:57 -0600
commit61c0c9187083584a60048cf88b8ef580957681e3 (patch)
tree5e7a074ab9f157e0250a5573879580ef0d8083ae /app-admin
parentx11-libs/libxkbcommon: Bump to version 0.10.0 (diff)
downloadgentoo-61c0c9187083584a60048cf88b8ef580957681e3.tar.gz
gentoo-61c0c9187083584a60048cf88b8ef580957681e3.tar.bz2
gentoo-61c0c9187083584a60048cf88b8ef580957681e3.zip
app-admin/ansible: 2.9.4 bump
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-2.9.4.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index 2a03fc551f08..4748c0c9ff41 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -3,3 +3,4 @@ DIST ansible-2.8.7.tar.gz 12697144 BLAKE2B f88225b358ff9fad352c04a053100c5aa612f
DIST ansible-2.8.8.tar.gz 12703583 BLAKE2B 0352646b495514d5a7a88fcd8e8437ef323f6d754f4704923b357c0f11c47932a2671a342e24f2de88479436f6f36664dbb0b26ee46fa98bc2d53d4f681595d0 SHA512 fb7705f3d0b8c0ee87d2954cccb7d00e12851693bbe995c062316577f66488f48d8180f11c8d87e025f4082a48ec27f25cb877be4c0ce96ed39951360e8679bd
DIST ansible-2.9.2.tar.gz 14157188 BLAKE2B 4c1207bd43f7797d8d9cb1d4612e866eebbf8c19ee060cf1eb7daa68415be5d7718c79d756454648e66a13434eacba6a07c8de31c4ec4b12e0474563d8844e46 SHA512 522dd84af9493ceafd95ff0fc806a671f3d1f10d0ca074ef41875eb966d39e64b834e0b98a35d81d9d9d96efef8069db604c8080ce8cbb1ce2e8b13bf5c30a6a
DIST ansible-2.9.3.tar.gz 14170666 BLAKE2B bb27d249e2390888ee3c28fdb48c1ceff346d2903089c70b451f793742238498aed7c33be056cce9790f44f5cdb74b5020b6decf4f1242904bd9c8f7b5077ea0 SHA512 02cfa2c7c43506dc602e92aed66c920243222b82bc4852f1a4d786cd3ff26fe17eda18d35ac7301cd9bf26366df9b18776e2a27e8d54fc92c3128f52ec7f58e8
+DIST ansible-2.9.4.tar.gz 14170264 BLAKE2B e230837360d29df460906d118b3c2ebb9a9dc1ac2a4427809a16716e67a79db8e737ed1beca757bd8a75b631c8cb6c26e58b1caeaaeb613731d63031f1e4e34e SHA512 21020548100fc31b59d4ee1b461f2a14359f2f18752d431cd041eb987c8c8b308f1aa1687461a9b3f5a086485b77b3a38c8f006b942cc24cb2157b45e6582822
diff --git a/app-admin/ansible/ansible-2.9.4.ebuild b/app-admin/ansible/ansible-2.9.4.ebuild
new file mode 100644
index 000000000000..87aa8f15ecba
--- /dev/null
+++ b/app-admin/ansible/ansible-2.9.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE="doc test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ dodoc -r examples
+}