summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleksandr Trotsenko <oleksandr.trotsenko@gmail.com>2018-02-12 05:24:27 -0600
committerCraig Andrews <candrews@gentoo.org>2018-02-13 11:29:15 -0500
commit6b266a983c7d94e83ba264d78892effbf17eeb9f (patch)
treeeb1e55edf6ba692034c91aab28316b7e464b8622 /app-admin
parentdev-php/PEAR-Numbers_Words: Version bump for 0.18.2 (diff)
downloadgentoo-6b266a983c7d94e83ba264d78892effbf17eeb9f.tar.gz
gentoo-6b266a983c7d94e83ba264d78892effbf17eeb9f.tar.bz2
gentoo-6b266a983c7d94e83ba264d78892effbf17eeb9f.zip
app-admin/apachetop: Bumping the version
Bumping to the latest available version of the package. Closes: https://bugs.gentoo.org/647116 Package-Manager: Portage-2.3.23, Repoman-2.3.6
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/apachetop/Manifest1
-rw-r--r--app-admin/apachetop/apachetop-0.17.4.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/apachetop/Manifest b/app-admin/apachetop/Manifest
index d99f1ce13051..49111859f763 100644
--- a/app-admin/apachetop/Manifest
+++ b/app-admin/apachetop/Manifest
@@ -1 +1,2 @@
DIST apachetop-0.12.6.tar.gz 126930 BLAKE2B 06d12cc72791920c959fa4ef8e18aa90f1f29a616389329685abf445f416cde9ce6edd2db5aaadaba51488033148e8109245200086a11422436ffe0aab1b4a40 SHA512 35081772f817c6a83a1fcf78790d2a288a9e4e48234c4b3163a09ad15f49a78d649b77f41aa002940fb9416c263cea159c5092a9b87285488eb450964c823c3a
+DIST apachetop-0.17.4.tar.gz 128153 BLAKE2B 7601ce98618d041f6fc67e528775ce79b63a726b765ff298d1d74a1dd22a4451be6c36669c7ab9bf82fb8c120a6930d2bbf03823de02a216c558c358c53c07be SHA512 b5115048f79c694344fd341631fe7739567ba3ce6e18514d0be250cb6f42e04c54d35cc023dea5258725fcbfbb6debdaa51b91d64ae3120e70f5b78a7989a330
diff --git a/app-admin/apachetop/apachetop-0.17.4.ebuild b/app-admin/apachetop/apachetop-0.17.4.ebuild
new file mode 100644
index 000000000000..2f5954eb82bf
--- /dev/null
+++ b/app-admin/apachetop/apachetop-0.17.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A realtime Apache log analyzer"
+HOMEPAGE="https://github.com/tessus/apachetop"
+SRC_URI="https://github.com/tessus/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="fam pcre"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ fam? ( virtual/fam )
+ pcre? ( dev-libs/libpcre )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-logfile="${EPREFIX}"/var/log/apache2/access_log \
+ --without-adns \
+ $(use_with fam) \
+ $(use_with pcre)
+}